Arduino nano 33 ble sens Serial monitor STOPS printing?!

Hello all,

I have tried to find the printing on the serial monitor issues on the forum, but somehow I was not successful, please excuse me, if this issue was addressed elsewhere, in this case, please let me know where!

I am using Arduino BLE 33 Sens on iMac and Arduino IDE 1.8.15

In general, I have noticed that I have to preset the RESET button quite often, if want to even work with this device, especially when checking the printout monitor...

I did a quick test to find out what is going on:

int a = 0;

void setup() {
  // put your setup code here, to run once:
 
  Serial.begin(9600);
  while(!Serial);

  
}

void loop() {
  // put your main code here, to run repeatedly:
  a++;
  Serial.println(a);
  delay(10);
}

This will run endlessly, and so it will appear on the serial monitor, it will print out on and on, no problems...

A bit more complicated code, that reads via the I2C the data, like sensor, will have problems, with stop printing out the information, like temperature, after a minute or so, very anoying!

Interesting, if the reset is pressed on a board, it will continue printing after several seconds...

If I run the same examples on the Arduino UNO, no such problems at all!

So, what is wrong with the NANO that needs to be reset after several time to work properly in terms of printing and reading the information from the sensor, for example?
What am I doing wrong? Why I do not get this issues on the Uno?

Looking forward to your reply!

Best.

The Arduino Nano 33 BLE uses native USB and the COM is virtual. The USB stack runs as part of your sketch on the same processor. If anything interferes with the stack you lose the USB connection and serial stops working.

On a Arduino Uno the USB connection is handled by a separate chip and you use a UART which is almost impossible to break.

I have not seen this issue on my computer so far. Do you get a blinking pattern on the Arduino? That would indicate it is not just USB Serial but mbedOS that crashed.

Can you provide a sketch that shows the issue?
Can you test this on another computer (Windows or Linux) to see whether the OS/USB host driver has an influence?