Arduino Nano BLE Sense 33 not Uploading Script

I received a new Nano BLE Sense 33 and I am greeted with the following error when I try to upload any script to the board.

Arduino: 1.8.10 (Windows 10), Board: "Arduino Nano 33 BLE"

In file included from C:\ProgramData\MATLAB\SupportPackages\R2018b\3P.instrset\arduinoide.instrset\idepkgs\packages\arduino\hardware\mbed\1.1.3\cores\arduino/mbed/platform/Callback.h:22:0,

                 from C:\ProgramData\MATLAB\SupportPackages\R2018b\3P.instrset\arduinoide.instrset\idepkgs\packages\arduino\hardware\mbed\1.1.3\cores\arduino/mbed/rtos/Thread.h:29,

                 from C:\ProgramData\MATLAB\SupportPackages\R2018b\3P.instrset\arduinoide.instrset\idepkgs\packages\arduino\hardware\mbed\1.1.3\cores\arduino/mbed/rtos/rtos.h:28,

                 from C:\ProgramData\MATLAB\SupportPackages\R2018b\3P.instrset\arduinoide.instrset\idepkgs\packages\arduino\hardware\mbed\1.1.3\cores\arduino/mbed/mbed.h:23,

                 from C:\ProgramData\MATLAB\SupportPackages\R2018b\3P.instrset\arduinoide.instrset\idepkgs\packages\arduino\hardware\mbed\1.1.3\cores\arduino/Arduino.h:32,

                 from sketch\sketch_dec25a.ino.cpp:1:

c:\programdata\matlab\supportpackages\r2018b\3p.instrset\arduinoide.instrset\idepkgs\packages\arduino\tools\arm-none-eabi-gcc\7-2017q4\arm-none-eabi\include\c++\7.2.1\new:39:10: fatal error: bits/c++config.h: No such file or directory

 #include <bits/c++config.h>

          ^~~~~~~~~~~~~~~~~~

compilation terminated.

exit status 1
Error compiling for board Arduino Nano 33 BLE.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

It looks like the mbed is installed in a MATLAB folder which does not make sense to me. I even went through and deleted the folder and reinstalled mbed but the folder was recreated. Any suggestions would be much appreciated.

Thanks!

Through further troubleshooting it seems to be a library issue. On my desktop application the library bits/c++config.h seems to be missing and on my raspberry pi installation libfl.so.2 seems to be missing. I thought this might have to do with the mbed installation so I tried installing an earlier version but that too did not work. An older arduino IDE I have on my laptop (1.8.9) gave a different error:

java.io.IOException: Cannot run program
"C:\Users\Jerrr36\Documents\ArduinoData\packages\arduino\tools\bossac\1.9.1-arduino1/bossac.exe": CreateProcess error=193, %1 is not a valid Win32 application

Again, any help would be appreciated.

jsh70:
on my raspberry pi installation libfl.so.2 seems to be missing.

There is information and fix for that specific issue starting here:

That solved it! Thanks!

I’m glad to hear it’s working now on your Raspberry Pi at least!

I assume you would still welcome some assistance with getting things working on your Windows machines.

Unfortunately, I don’t have any experience with MATLAB, so I can’t help you there. Perhaps someone else here on the forum will be able to provide assistance with that situation.

As for the problem on your laptop, please do this:

  • (In the Arduino IDE) File > Preferences
  • Uncheck the checkbox next to “Show verbose output during: compilation”
  • Check the checkbox next to "Show verbose output during: upload
  • Click “OK”
  • Sketch > Upload
  • After the upload fails, you’ll see a button on the right side of the orange bar “Copy error messages” (or the icon that looks like two pieces of paper at the top right corner of the black console window in the Arduino Web Editor). Click that button.
  • In a forum reply here, click on the reply field.
  • Click the </> button on the forum toolbar. This will add the forum’s code tags markup to your reply.
  • Press “Ctrl + V”. This will paste the upload output between the code tags.
  • Move the cursor outside of the code tags before you add any additional text to your reply.

I know this is not a new post but someone will need this. after hours of trying, I found this and it worked!

https://in.mathworks.com/matlabcentral/answers/421325-how-can-i-resolve-the-esp8266-compilation-error-caused-by-the-arduino-support-package

seems to be MATLABs messing with the Arduinos preference address.

credit goes to the original author

Haben Ghebremedhin -

"It turns out that when you use the arduino support package in matlab things get screw up a bit thats for mathworks to figure out but as for this issue you have to go to C:\Users\Your user name here \AppData\Local\Arduino15 and find the preference text file, in the file chage the settings.path to where you have your arduino...typically C:\Users\Your user name here \Docments\Arduino and that should fix it. "