Arduino Robot Control board problem[SOLVED]

I've been experiencing an issue with Arduino robot, after installing the example programs and running them I seem to have installed one example code that locked down the board.
Symptoms:

  • Windows PC(Laptop) does not recognize Robot Control board as a device.
    ~ Temporary "solution". When pressing the reset button the PC recognizes the RCB(Robot Control Board) for a brief moment and Arduino IDE sees the control port for a brief moment, however afterwards it disconnects. RCB disconnects itself, however the display still lights up and seems to draw power, the screen does not show any action besides simply lighting up, white screen.
  • Windows PC recognizes any other device such as Arduino Uno and Arduino Robot Motor board(one below)

Arduino in use(issue I have with)

https://store.arduino.cc/arduino-robot

The error messages I get in 2 cases:
Case1:(when I try to upload a blank program in the moment when I have PC recognize the Arduino during split moment after pressing reset button on RCB)
Sketch uses 3458 bytes (12%) of program storage space. Maximum is 28672 bytes.
Global variables use 149 bytes (5%) of dynamic memory, leaving 2411 bytes for local variables. Maximum is 2560 bytes.
An error occurred while uploading the sketch
avrdude: ser_open(): can't open device ".\COM8": The system cannot find the file specified.

Case2: After it's not registered, disconnected by itself(No I do not unplug the arduino from PC)
Sketch uses 3458 bytes (12%) of program storage space. Maximum is 28672 bytes.
Global variables use 149 bytes (5%) of dynamic memory, leaving 2411 bytes for local variables. Maximum is 2560 bytes.
Couldn't find a Board on the selected port. Check that you have the correct port selected. If it is correct, try pressing the board's reset button after initiating the upload.

Additional notes, I've tried several solutions such as using different cable and the solution proposed here in this forum topic:

And nothing had changed(and yes I installed the latest version of Arduino IDE)

Attachment includes a screenshot of the windows machine state while the Arduino is recognized and disconnected after few miliseconds

Due to the USB stack running on the same chip as your sketch with this board, it is possible for code in your sketch to break the USB functionality. Fortunately, the upload code (bootloader) is stored in a separate section of memory and can not be broken by the sketch code. The only tricky thing is that the bootloader has to be activated at just the right time during the upload. Normally this is done by some special code that runs in the background of your sketch code recognizing a 1200 baud connection as the signal to reset the microcontroller and start the bootloader. However, in your current situation, that system wont work so you’ll need to manually reset the board to activate the bootloader.

You need to get the timing right. If you press the reset button too early, the bootloader will have already timed out by the time the upload starts. The tricky thing is that when you press the “Upload” button in the Arduino IDE, it first compiles your sketch before starting the actual upload. So you need to wait until after the compilation finishes before pressing the reset button.

Do this:

Sketch > Upload

Watch the black console window at the bottom of the Arduino IDE window. As soon as you see something like this:

Sketch uses 444 bytes (1%) of program storage space. Maximum is 30720 bytes.
Global variables use 9 bytes (0%) of dynamic memory, leaving 2039 bytes for local variables. Maximum is 2048 bytes.

press and release the reset button.

After that, the sketch should upload successfully. After that, if the problem persists, you know there is something in your sketch that is breaking the USB functionality. You can verify this by uploading the File > New sketch, after which the board should be recognized by your computer and you should be able to upload normally. If so, you will need to find out what it is in your sketch breaking the USB code. Now that you know how to recover your board, that should be manageable.