AruinoBT frustration

Hello Everyone,

I am trying to work with two arduinoBT which I recently bought, but it is somehow like a nightmare. I'm using Arduino 010 on a windows xp2 macbook.

I have tried various systems and computers so far, and none of them has given me good results so far.

The system I have had most success with so far is a black macbook running windows. On the macosx10.5 side of the macbook, The Arduino IDE just hangs very badly and I have to restart the computer using the powerknob...

So on the winxp side: I have managed to get the right synchro between hitting the upload and the reset button (2,316 seconds before you reset the arduino, you press the upload button in the IDE :)

So I uploaded the Blink example to my BT, and it worked. I uploaded it again and it worked again. Then I uploaded a small program sending messages through the serial port, and ... Now I cannot connect to the Arduino via Bluetooth anymore, and when I am for the Bluetooth key and enter 12345 I get a reply that windows could not connect to the device.

Another problem (which I also had on another windows laptop) is that the Arduino IDE takes AGES (about 3minutes) to start up. I have seen another thread with the same problem but no clear solution. Anyone ? And the tools menu is also blocked.

I have changed to my other ArduinoBT in case the problem came from the Arduino I managed to program, but there is no change in the fact that the IDE takes ages to start and the tools menu also sort of stays stuck...

Sorry if this has been discussed before. I have looked at the forum and found other people with similar problem but no answer that I could apply to my case.

I am depressed.... help me Alain

i hd similar problems since using version 10 on a mac

version 9 was fine uploading but with 10 i cant upload and/or the bluetooth connection is busy and the arduino freezes the interface once a failed upload process has been done

Thanks for the reply unclevoid,

I tried with arduino 009, and at least it is not hanging, so this is good sign. But I have another problem now.

When I try to upload, I get the following message in the Arduino IDE

avrdude: ser_open(): can't open device "/dev/tty.ARDUINOBT-BluetoothSeri-1": Resource busy

And at the same time I a message window appears with something like (I'm trying to translate here)

There has been a bluetooth serial error Error opening a RFCOMM serial channel. Check, if necessary, that authentication is activated in the device

A google search gave this as an answer, but I cannot see what it means in my particular case...

Usually there are 3 reasons why that dialog appears: 1] The device with the RFCOMM channel you want * to connect to requires paring and you are not paired.* 2] You are attempting to open an RFCOMM channel ID * that does not exist.* 3] Something during the opening of the channel goes * really bad or does not happen and the timer that* * oversees the open sequence fires.*

Anyone can lead me towards a clue ? I do not know what pairing means...

In the Blutooth setup, I can see the Arduino and I can see the serial port created 'ARDUINOBT-BluetoothSeri-1' There is an option in the control panel that I can activate and which says (rough translation again) 'require securized link' but when I activate it and leave the panel and come back to it, it is deactivated again.

Anyway, I'll keep trying with other versions of Arduino IDE as they seem to behave differently,

Any help welcome,


well... apart from that in my experience bluetooth generally needs a bit of patience to deal with...

i got two macs set up, an intel mini and a macbook pro intel both run latest of tiger (not going close to leopard quite yet) the macbook seems to be fine(r) with the uploading process, the mac mini, despite both running 009 versions of arduino software is a bit more unreliable.

I havent quite figured out when to press the reset button on the board and when to press the upload button on the arduino software interface.

est guess at the moment is pressing the uplod button and straight away hold down reset on the board for a second, so that the upload process hits the board when it is resetting and not busy running the script (thats my theory)

that seems to work most of the times but not all the time

for your bluetooth being busy, i would recommend restarting the pc or mac and taking the arduino off power for about 10 secs or more that should reset it as bluetooth seemingly tends to get stuck sometimes, or drops sometimes, or might get funny if to many other radiowave devices are around.

Thats my 5 cents

Ok, Thanks !

I'll just keep trying with different timings and see if I manage to get it right.

Just to close this on a positive line... and in case someone ends up here after some unneeded frustration :)

I finally managed to upload on the mac side using Arduino 007 (with Leopard) and finding the right timing It does take some time, but having the Bluetooth control panel open at the same time as the Arduino IDE, one can see when the Arduino tries to connect to the ArduinoBT (the light goes green:) ), and what worked for me was to make the first connect sign coincide with the Reset on the Arduino.

On the windowsXP side, I decided to reinstall windows since I had some problems that seemed virus related :( Since the reinstall I managed to work with Arduino IDE 0010 and found the right timing, again with the control panel open..

HTH Ciao