Atmega328-PU bootloader issues

Hi Guys

Error message:

Arduino: 1.6.5 (Windows 8.1), Board: “ATmega328 on a breadboard (8 MHz internal clock)”

C:\Program Files\Arduino\hardware\tools\avr/bin/avrdude -CC:\Program Files\Arduino\hardware\tools\avr/etc/avrdude.conf -v -patmega328p -cstk500v1 -PCOM6 -b19200 -e -Ulock:w:0x3F:m -Uefuse:w:0x05:m -Uhfuse:w:0xDE:m -Ulfuse:w:0xFF:m

avrdude: Version 6.0.1, compiled on Apr 15 2015 at 19:59:58

Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/

Copyright (c) 2007-2009 Joerg Wunsch

System wide configuration file is “C:\Program Files\Arduino\hardware\tools\avr/etc/avrdude.conf”

Using Port : COM6

Using Programmer : stk500v1

Overriding Baud Rate : 19200

AVR Part : ATmega328P

Chip Erase delay : 9000 us

PAGEL : PD7

BS2 : PC2

RESET disposition : dedicated

RETRY pulse : SCK

serial program mode : yes

parallel program mode : yes

Timeout : 200

StabDelay : 100

CmdexeDelay : 25

SyncLoops : 32

ByteDelay : 0

PollIndex : 3

PollValue : 0x53

Memory Detail :

Block Poll Page Polled

Memory Type Mode Delay Size Indx Paged Size Size #Pages MinW MaxW ReadBack


eeprom 65 20 4 0 no 1024 4 0 3600 3600 0xff 0xff

flash 65 6 128 0 yes 32768 128 256 4500 4500 0xff 0xff

lfuse 0 0 0 0 no 1 0 0 4500 4500 0x00 0x00

hfuse 0 0 0 0 no 1 0 0 4500 4500 0x00 0x00

efuse 0 0 0 0 no 1 0 0 4500 4500 0x00 0x00

lock 0 0 0 0 no 1 0 0 4500 4500 0x00 0x00

calibration 0 0 0 0 no 1 0 0 0 0 0x00 0x00

signature 0 0 0 0 no 3 0 0 0 0 0x00 0x00

Programmer Type : STK500

Description : Atmel STK500 Version 1.x firmware

Hardware Version: 2

Firmware Version: 1.18

Topcard : Unknown

Vtarget : 0.0 V

Varef : 0.0 V

Oscillator : Off

SCK period : 0.1 us

avrdude: AVR device initialized and ready to accept instructions

Error while burning bootloader.

Reading | ################################################## | 100% 0.05s

avrdude: Device signature = 0x1e9514

avrdude: Expected signature for ATmega328P is 1E 95 0F

Double check chip, or use -F to override this check.

avrdude done. Thank you.

This report would have more information with
“Show verbose output during compilation”
enabled in File > Preferences.

Let me start by saying I know this is a well known and well documented issue. I have read many workarounds for this but cannot get it working.

I have an Arduino UNO and a new Atmega328-PU on a breadboard. I have wired it up as per the many diagrams around and believe it is wired OK. I do not have a crystal so am using it with no crystal again as per the many instructions.

The Arduino ISP sketch has been uploaded to my Arduino UNO

The image is of the Arduino IDE 1.6.5

There is no issue using the Arduino UNO, I can upload sketches and communicate with it fine. I am trying to offload my project onto a bare bones board for final install just can’t seem to crack it.

I am running Windows 10

Don’t know what else to tell you pretty much I can run the IDE with no avrdude.conf file and get the same result. I can write what ever I want to the file and I will get the same error message.

Any help appreciated.

My avrdude.conf has been changed

part
id = “m328P”;
desc = “ATmega328P”;
has_debugwire = yes;
flash_instr = 0xB6, 0x01, 0x11;
eeprom_instr = 0xBD, 0xF2, 0xBD, 0xE1, 0xBB, 0xCF, 0xB4, 0x00,
0xBE, 0x01, 0xB6, 0x01, 0xBC, 0x00, 0xBB, 0xBF,
0x99, 0xF9, 0xBB, 0xAF;
stk500_devcode = 0x86;

avr910_devcode = 0x;

signature = 0x1e 0x95 0x14;

.
.
.
.
part parent “m328”
id = “m328P”;
desc = “ATmega328P”;
signature = 0x1e 0x95 0x14;

ocdrev = 1;

Invalid signature - there is difference in signature between 328 and 328P chip. P means pico power. No big problem. You have to edit signature in boards.txt file and in avrdude.conf to add section for 328 because there is only 328P.

Thanks for that

Now have this error.

Happy with this error as it tells me something and am making progress. I have changed so much I will go and double check everything and see if I can find problem.

Thanks for the help

avrdude: Device signature = 0x000000
avrdude: Yikes! Invalid device signature.
Double check connections and try again, or use -F to override
this check.

Cheers

This error means that the programmed device is no connected. Carefully check the wiring, port on OS, etc. Previous situation was good from this point of view because PC was able to communicate so you have had to broke some wire connection or something other.