ATMega64 16AU

Hello Chaps.

I recently got my hands on a big batch of nice PCB's with a lot if I/O (Relays, optocouplers etc.) and want to use them in a project.

I tried searching the forums, but didn't find an answer.

Is it possible to bootload the ATMega64 witn an Arduino bootloader (and which) or is the part too old ?

I have no problem compiling the bootloader from source, i just need some guidance on how to do this...

The Xtal is 7.372MHz - i'm gonna replace this with an 8 or 16 MHz one....

Regards,

Per.

I don't see any reason why you couldn't put an Arduino bootloader on them, because the atmega6416au is like the atmega328au but with twice the memory. All that's missing is the "P" for low power.

Alternatively, you could programming them directly without using a bootloader.

OK.

I tried setting up my Arduino environment for a Sanguino, and i cannot get in contact with the Atmega64.

I have connected Mosi,Miso, Rst, Sck, VCC, GND to my Arduino Mega (acting as a ArduinoISP device at the moment...)

I don't know if the chip is locked down - probably.

Avrdude says incorrect device signature - but it sais that too with the board disconnected, so :-O

// Per.

Did you create a new board definition in boards.txt for the atmega64? If so, what parameters did you use?

Check here for files for that device, will help the process along. http://www.avr-developers.com/

Cool.

I did add the entry for "Cerebot II" in my boards.txt and now i cannot communicate with my Mega64 trough my USBASP.

The problem is, no matter what pins i address, nothing happens on them.

There is no pins_arduino.c that is special for the Atmega64, so i do not really know what goes where.

I am unsure about the fuses too - i guess that USBASP does not touch the fuses (i am not using a bootloader for the chip) - is there a general advice regarding setting the fuses ?

// Per.

Did anyone ever get the board definition in boards.txt for the atmega64 to work? I have a custom circuit with the atmega64, I would like to use the Arduino IDE to program it. I have the AVRISPMKII programmer and the circuit has the isp built on to it. I have programmed it using the AVr studio so I know it works. I have switched the driver to the avrdude driver. Swithed to Cerebot II loaded from http://www.avr-developers.com/ and all I get are errors when trying to blink a led.

Blink.cpp:8:21: error: Arduino.h: No such file or directory
Blink.cpp: In function ‘void setup()’:
Blink:10: error: ‘OUTPUT’ was not declared in this scope
Blink:10: error: ‘pinMode’ was not declared in this scope
Blink.cpp: In function ‘void loop()’:
Blink:14: error: ‘HIGH’ was not declared in this scope
Blink:14: error: ‘digitalWrite’ was not declared in this scope
Blink:15: error: ‘delay’ was not declared in this scope
Blink:16: error: ‘LOW’ was not declared in this scope

I think the atmeg64 definitions are not configured right.

I realise that this thread has been quiet for a while, but it may still be of use to someone who may find it in a web search for the problem in question.

Connecting your programmer to MOSI and MISO on a Mega64 or 128 will not work. ATMEL used pins PortD.0 and PortD.1 for these functions on these devices for some unknown reason. They are also the pins for the first UART. The reset and clock pins are as per usual.

The MOSI and MISO pins still work as normal for an ISP port, but not used for programming.

Check the data sheet, it covers the topic.

Cheers Bigfootnz

Hi to all. I try to find solution for using , like Zapro from start of this discussion and nothing :(

I have simple Atmega 64 board and I want to use Arduino libraries and code which I write for Mega2560 (with some modification because of different chip) on that board.

Like I understand answers from "google" there is NO solution . Question is - where is a main problem ? I find that Mark Sproul try something (2010)- some header files where is a Atmega64 definition in Arduino context .

Another small hope for solution is "cerebot II" but I didn't find any part of code or sign that somebody was successful in Arduino code use on Atmega 64 chips. If exist some idea , please send here .