avrdude - not responding & other problems

Hi,

I just tried to get started with my YUN. When uploading Sketches to the Yun the following error occurs:
root@Arduino:/etc/arduino# run-avrdude ./base.hex

avrdude: AVR device not responding
avrdude: initialization failed, rc=-1
Double check connections and try again, or use -F to override
this check.

avrdude done. Thank you.

If I try to read the value of a single pin (http://arduino.local/arduino/analog/28) I get the following message:
Could not connect to YunServer 146 Connection refused

What is the problem here?
I've googled a lot and this post won't help me:

If I change the value and fire up this:

/usr/bin/run-avrdude    /etc/arduino/Caterina-Yun.hex

I get the same error as above from avrdude.

I did an upgrade to the latest software. (http://arduino.cc/en/Main/Software#toc8)
I have tried it both with the windows and mac ide (beta for yun)
Please help me :slight_smile:

Thank you,
nitramf

I believe you are using the network connection to upload sketches, correct? If so try the links below, also confirm that you can upload sketches through USB.

Try this Wifi Sketch upload avrdude error rc=-1 (SOLVED) - #10 by noblepepper - Arduino Yún - Arduino Forum, while using a voltmeter to see if MISO changes is the definitive answer, Quiggers found Wifi Sketch upload avrdude error rc=-1 (SOLVED) - #12 by Quiggers - Arduino Yún - Arduino Forum his gpio to enable the voltage translator did not change in Linino so check that first.

It does not appear in the port-list (both on mac and windows)

maybe I try to get it solved with an exchange.

It sounds like there are troubles on the 32u4 side, when you press the 32u4 reset does the yellow led flash 1-2 seconds later? If not a n exchange may be the best course...

Does it work if you use the Arduino IDE instead?
Regarding the "connection refused": does the sketch use Bridge?