AvrispMKii programmer, problems burning bootloader on Arduino and attiny chips

Dear all I'm writing you this time because im starting to have again problems with my AVRSIPmkII programmer, until now i was able both to program Arduinos and other chips as Attiny85 or Attiny 2313, and to burn bootloaders on all those chips.

After latest releases of Arduino environment I can load the program, (Sketch), without any problem on Arduinos and attinies, but I'm not able to burn bootloaders on the aforementioned chips, i always get the same message:

avrdude: usbdev_open(): did not find any USB device "usb"

Do you have any idea about?

Yes, I've had problems with certain builds of avrdude. Which IDE version are you using? Can you show the full error message?(You may need to check show verbose for Uploads in Preferences).

What platform OS are you using for the IDE?

Dear all, I have the same problem: using IDE 1.6.1 on Win7 X64, i am not able to burn bootloaders anymore with AVRISP MK2, error message:

avrdude: Version 6.0.1, compiled on Jan 15 2015 at 16:58:43 Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/ Copyright (c) 2007-2009 Joerg Wunsch

System wide configuration file is "C:\Program Files (x86)\Arduino/hardware/tools/avr/etc/avrdude.conf"

Using Port : usb Using Programmer : stk500v2 avrdude: usbdev_open(): did not find any USB device "usb"

Strange: Burning sketches with the programmer still works. Also burning a bootloader with Atmel 6.2 Studio and Visual Micro still works.

cheers Sven

So there were a few known issues with avrdude v6.0.1 and AVRispMKII programmers. The one I most encountered was back-to-back access. If you do single avrdude access from command line or IDE uploads then it works fine. But for IDE Burn Bootloader access it will write fuse first then write the bootfile. It will usually succeed at burning the fuses, but then immediately fails at writing the bootfile, with the "did not find any USB device" error. I think there was some issue with how long Windows takes to re-open the USB for back-to-back operations.

It seems to be fixed in avrdude v6.1. You can try this Windows pre-built download from the official site, http://download.savannah.gnu.org/releases/avrdude/avrdude-6.1-mingw32.zip

Or for those who want to build their own version, http://download.savannah.gnu.org/releases/avrdude/avrdude-6.1.tar.gz

Dear hiduino, Perfect! Updating to avrdude 6.1 solved the problem!

many thanks for the quick help!

cheers Sven

Thanks to all of you for your answwers, i will check your proposals, and i'll come back with my conclusions.

Thanks again.

regards.

Dear all, hi again, I'm still in the same position, I can load the program using programmer AVRSIPmkII, but I cannot upload bootloader,

I have an Arduino Uno too where I cannot load the sketch using the common USB connection, only I can do it using programmer, probably the bootloader is missing, but at this moment I cannot load bootloaders, but I can load sketches using AVRSIPmkII programmer, I was tried with the software suggested by hiduino,

(http://download.savannah.gnu.org/releases/avrdude/avrdude-6.1-mingw32.zip )

, without results, probably I'm placing it in the wrong place or I was not understood how to use it, today mi configurations are as follows, Windows 8.1, Arduino IDE 1.6.2, any idea?, thanks a lot for your help.

Testing an Arduino Leonardo i can load the sketch using the normal usb cable, then i need to focus in burn bootloaders from AVRSIPmkII

For IDE 1.6.2 they moved the tools to,

%USERPROFILE%\AppData\Roaming\Arduino15\packages\arduino\tools\avrdude\6.0.1-arduino2\etc\avrdude.conf
%USERPROFILE%\AppData\Roaming\Arduino15\packages\arduino\tools\avrdude\6.0.1-arduino2\bin\avrdude.exe

Now i'm trying and looks good, tested only with an Arduino UNO it seems like working, i can upload the sketch both via USB or AvrispMKii, and i can burn the Bootloader too, thanks for your help.

Regards:

JMEC

Hi to all of you, bad news again, I was upgraded to IDE 1.6.3, and I can use the AVRSIPmkII to upload sketches on Arduino Uno and Leonardo, Attiny 85, Attiny 2313 and Attiny 4313, and I can also burn bootloaders in all of them but in Attiny 4313, every time I try to burn the bootloader on a 4313 I get this error:

avrdude: reading input file "C:\Users\JoseM\Documents\Arduino\hardware\tiny\avr/bootloaders/empty4313at1.hex" avrdude: can't open input file C:\Users\JoseM\Documents\Arduino\hardware\tiny\avr/bootloaders/empty4313at1.hex: No such file or directory avrdude: read from file 'C:\Users\JoseM\Documents\Arduino\hardware\tiny\avr/bootloaders/empty4313at1.hex' failed Error quemando bootloader avrdude done. Thank you. For me is too curious to have this file with the half of the length of same file referred to Attiny 2313;

Ideas?

Thanks a lot for your help.