Bitbucket

Does anyone know how to clone a bitbucket repository onto the yun? I keep getting this error:

ssh: Connection to git@bitbucket.org:22 exited: No auth methods could be used. fatal: Could not read from remote repository.

Please make sure you have the correct access rights and the repository exists.

ssh-keygen does not work with dropbear aparently. I cannot figure out how to create an id_rsa.pub file.

You could use command "dropbearkey" (I can't test it atm, so let us know if it works) http://linux.die.net/man/8/dropbearkey

Tried that and I get the same error as before.

This is actually a more general question. Has anyone managed to get dropbear to work with bitbucket or has anyone managed to get openssh installed on a yun?

After some more testing, it looks like dropbear is not powerful enough for cloning a git repo Here is how I managed to clone a repo of mines

opkg update
opkg install --force-overwrite openssh-client #see below
opkg install openssh-keygen
opkg install git
ssh-keygen
cat /root/.ssh/id_rsa.pub #and then pasted the output on github
git clone myrepo...

Pay attention that that --force-overwrite will overwrite ssh and scp with the (fully featured) ones from openssh. These are clients commands and replacing them WON'T affect the ssh server. If you prefer to have a full openssh installation, you'll have to remove dropbear, install openssh-server and configure it. Do that from a yunserialterminal, as you will likely lose the ssh connection in between