Bug with usb hub

Hello everyone, I want to post a new topic because I can’t find any help for my problem. :drooling_face:
I have a netbook and I use some usb hubs to conect all of my devices. When I want to connect my arduino uno in one of my usb ports, I see 21 serial ports in my arduino software (WTF). It’s not really easy to find the good one :~
I have try without my usb hub but It doesn’t solved the problem. I have try to unistall arduino too but It didn’t solved anything.
I hope you can help me with this because It’s not really handy…
(Sorry for my bad english, I have posted It in the english forum for a quick answer)

under windows you can go to
start -> computer -> manage -> devices -> comports...

might help

Thanks for your help ! In fact, I can see more than 15 usb ports in "devices" (O_o)
My computer have only 3 usb ports, maybe 7 with the hub....
I found the right port (COM9) but It will change for each arduino board I will use...

Sometimes USB ports don't get cleaned up well.
You could try to disconnect all (except mouse) and remove some that "smell old"