burning bootloader

Hello everyone,

I trying to burn the Uno bootlader on one of my Nanos. I did this many times but for some reason it is not working now.

I use an Uno as programmer and connected

UNO <----> NANO
13          13
12          12
11          11
10          RST
+5V         +5V
GND         GND

I uploaded the ISP to the Uno and set the Programmer of Arduino IDE: Arduino as ISP

When I burn the bootloader I get the following error message.

avrdude: stk500_getparm(): (a) protocol error, expect=0x14, resp=0x14

avrdude: stk500_getparm(): (a) protocol error, expect=0x14, resp=0x01
avrdude: stk500_initialize(): (a) protocol error, expect=0x14, resp=0x10
avrdude: initialization failed, rc=-1
         Double check connections and try again, or use -F to override
         this check.

avrdude: stk500_disable(): unknown response=0x12
Error while burning bootloader.

I looked for the errormessages but these are generic errorcodes which wont explain whats wrong with the program.
I reconnected all cables multiple times (which usually works) but still the same error.

I am using: Arduino IDE 1.8.5 on Ubunt 16.04

Thanks for the help

Put a 10uF capacitor across Rst and Gnd on the Uno used as a programmer.

I saw that in

https://forum.arduino.cc/index.php?topic=111110.0

and I used a 10uf and 0.1uf and the error persists.

I tried the same on a machine of my colleague (Win10, Arduino IDE 1.8.2) and it worked. I also noticed the option in the processor to choose Atmega328 (old bootloader). The 1.8.2 version does not has this option yet.

My followup question: Is this due to the new version of the IDE and the ISP file has to be updated or because of the OS?

I do not want to purge the IDE on Ubuntu and install 1.8.2 because everything is running smoothly and I dont know if I can restore all the links, libraries, etc to the build I currently have.

The difference in the Tools > Processor menu, and likely the error you're getting as well is a matter of Arduino AVR Boards version, not IDE version. The two are somewhat coupled in that each Arduino IDE release comes with the latest release of Arduino AVR Boards at that time. However, you can use Boards Manager (Tools > Board > Boards Manager) to install any version of Arduino AVR Boards on any version of the Arduino IDE so it really doesn't make sense to associate a particular version of Arduino AVR Boards with a particular version of the Arduino IDE. When a new version of Arduino AVR Boards is released, the Arduino IDE will persistently nag you to update (assuming you haven't disabled that option in File > Preferences) until you do it. It's quite common for people to forget they even did the update, or not know what exactly they did, and then get quite confused about why something broke mysteriously.

So it was the update? Not from the IDE, but from the AVR boards.

I found the boards in the library

Arduino AVR Boards 1.6.23

I have to check the version of my colleague tomorrow and see if this was the problem. Then I have to revert?

I still do not understand how a new version of avrdude derails a sketch I used many times and many updates ago?

v3xX: Then I have to revert?

It's worth a try. It only takes a minute to do and you can always spend another minute switching back to 1.6.23.

v3xX: I still do not understand how a new version of avrdude derails a sketch I used many times and many updates ago?

Burning a bootloader has absolutely nothing to do with a sketch. It's possible that different versions of avrdude are not the cause of your issue, but it's much more likely than different IDE versions. The Arduino IDE is just running a couple avrdude commands when you click Tools > Burn Bootloader.

For all still interested.

I tried reverting all libraries to the working versions of windows and it still did not help. I set all my devices using my colleagues workstation (I am too afraid to purge my IDE and libraries) and hopefully I am not in need of a new bootloader soon.

Maybe after the next iteration of updates its working on 16.04 again (at least I have found a purpose for windows)

Thanks for the help everyone