Can´t open device; COM1

Hey there!
I’ve bought an arduino nano and now wanted to run my first programm on it. I’ve already tried some things with an uno, so I’m not a completly beginner.
Now my problem:
I could compile my sketch but when I want to upload it, there comes this alert:

avrdude: ser_open(): can’t open device “\.\COM1”: Das System kann die angegebene Datei nicht finden.

(means the system can’t find my sketch)

I also CAN’T select a port under tools. maybe that’s the problem?

Thanks for help in advance!
Julia

COM1 would indicate Windows? If so, check what Windows device manager thinks about your board. Clones often use a different TTL-to-USB chip, most common is the CH340 (although there are others); check what’s written on the chip at the underside of the board. You will need to download and install the driver for it; for the CH340, CH341SER.ZIP - 南京沁恒微电子股份有限公司, don’t worry that it’s a Chinese website.

If not Windows, check what your operating system thinks about it.

Thank you for the advice!
Yes, it’s windows, but it’s no clone, it’s from arduino.cc
So actually I can be sure, that it’s the correct driver, can’t I?

In this case, you can be sure that’s not the correct driver. Although it is the most common for the 3rd party derivative boards, none of the official Arduino boards you would buy from store.arduino.cc use the CH340 USB chip.

The official Nano uses the FTDI FT232R USB chip instead. There are drivers for that in the drivers subfolder of the Arduino IDE, or you can get it from the FTDI website.

But the first thing to do is to see if a device shows up in Windows Device Manager after you plug in your Nano, as sterretje mentioned. If there is a device, then the fix is likely to install the driver. If there is no device, then we can look for another solution.

1 Like

There was a device in the device manager called FT232R USB UART.
Then the driver was installed. Now I can’t see the device anymore. I still cant upload the sketch onto the board, but this time it’s different: At least I can choose the port COM 3.
My error now is:

avrdude: Version 6.3, compiled on Jan 17 2017 at 12:00:53
Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
Copyright (c) 2007-2014 Joerg Wunsch

     System wide configuration file is "C:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf"

     Using Port                    : COM3
     Using Programmer              : arduino
     Overriding Baud Rate          : 57600

Beim Hochladen des Sketches ist ein Fehler aufgetreten

Thanks in advance!

I order to gather more information that might help us to troubleshoot your problem, I’m going to ask you to post the full output from the upload when in verbose mode.

Please do this:

  1. Select File > Preferences from the Arduino IDE’s menus.
  2. Uncheck the checkbox next to Show verbose output during: [ ] compilation
  3. Check the checkbox next to Show verbose output during: [ ] upload.
  4. Click the OK button.
  5. Attempt an upload, as you did before.
  6. After the upload fails, you’ll see a button on the right side of the orange bar Copy error messages. Click that button. This copies the full output to the clipboard.
  7. Open a forum reply here by clicking the Reply button.
  8. Click the </> icon on the post composer toolbar. This will add the forum’s code block markup (```) to your reply to make sure the error messages are correctly formatted.
    Code block
  9. Press Ctrl+V. This will paste the error output from the upload into the code block.
  10. Move the cursor outside of the code tags before you add any additional text to your reply.
  11. Click the Reply button to post the output.
1 Like

I did exactly what you told me to do.
After attempting an upload, there’s this green bar, where the “copy error message” button would pop up. And on the left side there’s “Hochladen…” means “Uploading…”. So it just won’t finish uploading.
Everything I can read now is:
Archiving built core (caching) in: C:\Users\JGOEBHA\AppData\Local\Temp\arduino_cache_951146\core\core_arduino_avr_nano_cpu_atmega328_0c812875ac70eb4a9b385d8fb077f54c.a
Der Sketch verwendet 2096 Bytes (6%) des Programmspeicherplatzes. Das Maximum sind 30720 Bytes.
Globale Variablen verwenden 198 Bytes (9%) des dynamischen Speichers, 1850 Bytes für lokale Variablen verbleiben. Das Maximum sind 2048 Bytes.
C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avrdude -CC:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf -v -patmega328p -carduino -PCOM3 -b57600 -D -Uflash:w:C:\Users\JGOEBHA\AppData\Local\Temp\arduino_build_591269/sketch_may04c.ino.hex:i

avrdude: Version 6.3, compiled on Jan 17 2017 at 12:00:53
Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
Copyright (c) 2007-2014 Joerg Wunsch

     System wide configuration file is "C:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf"

     Using Port                    : COM3
     Using Programmer              : arduino
     Overriding Baud Rate          : 57600

Okay, after 5 minutes it finished uploading.

Arduino: 1.8.5 (Windows 10), Board: "Arduino Nano, ATmega328P"

Archiving built core (caching) in: C:\Users\JGOEBHA\AppData\Local\Temp\arduino_cache_951146\core\core_arduino_avr_nano_cpu_atmega328_0c812875ac70eb4a9b385d8fb077f54c.a
Der Sketch verwendet 2096 Bytes (6%) des Programmspeicherplatzes. Das Maximum sind 30720 Bytes.
Globale Variablen verwenden 198 Bytes (9%) des dynamischen Speichers, 1850 Bytes für lokale Variablen verbleiben. Das Maximum sind 2048 Bytes.
C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avrdude -CC:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf -v -patmega328p -carduino -PCOM3 -b57600 -D -Uflash:w:C:\Users\JGOEBHA\AppData\Local\Temp\arduino_build_591269/sketch_may04c.ino.hex:i 

avrdude: Version 6.3, compiled on Jan 17 2017 at 12:00:53
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2014 Joerg Wunsch

         System wide configuration file is "C:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf"

         Using Port                    : COM3
         Using Programmer              : arduino
         Overriding Baud Rate          : 57600
Beim Hochladen des Sketches ist ein Fehler aufgetreten

Dieser Bericht wäre detaillierter, wenn die Option
"Ausführliche Ausgabe während der Kompilierung"
in Datei -> Voreinstellungen aktiviert wäre.

Please try this:

  1. Select Tools > Board > Boards Manager from the Arduino IDE’s menus.
  2. Wait for the update to finish.
  3. From the list of available boards platforms click on “Arduino AVR Boards”.
  4. Click the Update button.
  5. Wait for the update to finish.
  6. Click the Close button.

Now try the upload again.

1 Like

Thank you!!! Now it works!

You’re welcome. I’m glad to hear it’s working now. Enjoy!
Per

1 Like

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.