Can't upload to Arduino Uno R3

i tried to upload a few programs and after some time it gives error, which is given in the attached picture and while i press SHIFT + UPLOAD button it gives the following error: " avrdude: usbdev_open(): did not find any USB device “usb” ". I also included a picture of the arduino while connected to the PC. I already performed all the things mentioned in the Troubleshoot page. It would very very helpful if anyone can provide a solution.
Thank you.

Why are you doing SHIFT + UPLOAD? That's Upload Using Programmer. You need a programmer connected to your Uno to upload that way. If you're trying to upload as usual with the Uno connected to your computer via USB you just want to click the upload button, don't press shift. If normal upload isn't working then you need to figure out why not.

i was following the instructions given here : https://www.arduino.cc/en/guide/troubleshooting#upload.

"The messages displayed when you try to upload with verbose output enabled. To do this, hold down the shift key while clicking on the upload button in the toolbar."

That’s completely wrong. Maybe that was how the IDE worked a long time ago. I’ve noticed that troubleshooting page is just terrible, which is a shame because that’s where they direct you to go when you’re having a problem. Shift+upload is the same as Sketch > Upload Using Programmer. You can see the text to the right of the upload button when you hover over it change from “Upload” to “Upload Using Programmer”. To get verbose output do File > Preferences > Show verbose output during > upload(check). I highly recommend always leaving that option checked. Even if you don’t understand all the output it’s nice to see the progress of the upload.

Thank you pert, but i didn't exactly get a solution to my main problem. I added another image for diagnosis. And also it is better to mention that i cannot RESET the arduino.

I’ve reported the error on the troubleshooting page at: [website]Troubleshooting page gives wrong instructions for verbose output during upload · Issue #5194 · arduino/Arduino · GitHub.

When you post error output to the forum please copy by clicking the “Copy error messages” button on the right side of the orange bar and paste it in a forum message using code tags(</> button on the toolbar). This will make it much more likely for you to get help because a lot of people here won’t bother to open photos and it can be useful to be able to select parts of the output you posted as text.

The error in the troubleshooting page has now been fixed. Thanks for bringing this to our attention Jahedul_Anowar!

Did you ever find a solution to your problem?