Connecting to Arduino Mega 2560 (Windows 8)

Hi,

I'm working with 3D printers for my first co-op term and am new to Arduino use. I am having trouble communication with my board even after watching many tutorials.

When I plug it in with my USB cable the LED does not light up, and the Arduino software will not allow me to select a port. Also, when I go to Device Manager the "Ports & COMs" option does not appear so I have no way of determining which COM my Arduino is using.

I'm thinking this means I am lacking power for the Arduino and should try an adapter, am missing something with my driver files, or have a bad board (possibly bad USB?).

Any help would be greatly appreciated, the area I'm most foggy with is drivers and could see myself having made a mistake there.

Thanks!

The problem you described would most likely be caused by either a bad board or a bad USB connection. The fact that the Leds do not light, could suggest that the board is not getting power. Try a different USB cord.

Let me know if this helps.

Did you try measuring at the 5V/Gnd pins to see if the board is powered?

I tried a new USB cable, still no connection or LED function. Do you have any other thoughts?

I haven't tried measuring for power using a voltmeter yet because the arduino mega is attached to a RAMPS 1.4 board and I was reluctant to take the thing apart. Is this something you would suggest so that I'm just dealing with the arduino for now?

Can you access the bottom of the Mega board? The two ends of the 2x18 connector are +5 on end and Gnd on the other. Can you get a reading there?

I was able to get a reading of 50mV at best from the other side, often around 20mV. Any thoughts on what that might mean?

I should note for comparison that it was reading precisely zero when the USB was unplugged, so some voltage appears to be getting through

Hi guys, I'm still having trouble with this. Does this likely mean that the board is broken? I still need to try using an external power source.