Connecting to Programmer Message?

I suddenly started getting the message below after uploading a sketch (2.0 beta 5). I have no idea what I did to turn this on, or how to turn it off. Restarting the IDE or powering down the Arduino Leonardo does not turn the message off. However, I do not get this message if I switch to an Arduino Uno, so I must have turned something on in the Arduino Leonardo.
Thanks for any help,
Al
Compilation complete.
Connecting to programmer: .
Found programmer: Id = “CATERIN”; type = S

  • Software Version = 1.0; No Hardware Version given.*
    Programmer supports auto addr increment.
    Programmer supports buffered memory access with buffersize=128 bytes.
    Programmer supports the following devices:
  • Device code: 0x44*

You probably have verbose output during upload enabled in the preferences.

  1. Select File > Preferences from the Arduino IDE’s menus.
  2. Uncheck the box next to “Show verbose output during: Upload”.
  3. Click the OK button.

However, I would recommend leaving verbose output during upload on. The reason is that it provides some feedback on the progress of the upload during a successful upload, and essential information for troubleshooting a failed upload. So it’s always useful.

Unlike the upload output, I don’t recommend people to leave the verbose compilation output turned on all the time. The reason is that it generates a huge amount of output that isn’t really very useful, except for rare cases where you need to troubleshoot the Arduino IDE’s compilation functionality itself, not problems with your code. All that output makes it more difficult to read the useful compiler warning or error messages.

The Uno uses a different upload protocol, so its upload output is different.

Thanks for the reply.
Verbose output is off, I’ve checked that a number of times. I’ve also tried uninstalling and reinstalling the IDE, but the verbose output persists. There probably is a preferences txt or ini file somewhere that has the verbose output set and is not responding to the normal preferences setting. Verify after upload is also off although I did try turning that on for a short while at one point. While I agree it might be good to have the verbose output on at times, I’d like to be able to control it. Perhaps there is a bug in beta 5?
Al

Can someone explain when you would expect to see the message below? What is connecting to what programmer? I get the impression you would see this message if setting up to either reprogram the Leonardo’s Boot Loader perhaps, or if the Leonardo was going to be used as a programmer for another Arduino’s Boot Loader. I have no experience with programming Boot Loaders but maybe I somehow got the Leonardo into a programming mode. If so, then maybe I can figure out how to get it out of that mode.
Thanks,
Al

Compilation complete.
Connecting to programmer: .
Found programmer: Id = “CATERIN”; type = S

  • Software Version = 1.0; No Hardware Version given.*
    Programmer supports auto addr increment.
    Programmer supports buffered memory access with buffersize=128 bytes.

Programmer supports the following devices:

  • Device code: 0x44*

I ran some simple experiments with the Arduino Leonardo on two different computers. If I upload the little Blink sketch using the ‘old’ 1.8.13 IDE, I do not get the
Connecting to programmer: .
Found programmer: Id = “CATERIN”; type = S… etc.,
message listed above. But I do get it with the same Blink program when using IDE 2.0 Beta 5. I also don’t recall getting the Connecting to programmer: message with earlier versions of IDE 2.0. So it would seem there is a bug or some kind of conflict with the latest 2.0 beta 5 and the Leonardo. I would like to hear if any other Arduino users are seeing something similar.
Thanks,
Al

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.