Did I fry my NodeMCU?

Extremely bad idea! :roll_eyes:

prove it

Dang, looks like something else is fried. I installed the new regulator and it’s still not working. But oh well, it works through 3.3V on the board and I can still program it with external power and USB so I’ll just leave it.

With new regulator, the voltages are as in post # 1 ?
Do you use the same USB port for another device ?
You may need to cut cable and measure the current consuming by ESP8266.
There are two option

  1. your USB port on your pc is not good
  2. short circuit on your ESP between micro USB and voltage regulator
    Measure resistance to ground with voltage regulator on PCB.

Which model of ESP8266 you have, show the picture.

Same voltages as earlier, 1.9 and 0.9.
I have two other identical (as far as I can tell) NodeMCU devices which work flawlessly on this same USB cable and USB port, which this device also worked fine on up until I broke it, so it’s a virtual impossibility that the issue is anywhere except inside this NodeMCU.
Using 3V3 from a Seeeduino Xiao, this is the current usage I’m measuring to the broken MCU: 0.8mA. Although, when in uA mode, my DMM says 8uA, which is a bit of a disparity. I may need a higher end DMM to measure small currents accurately or a shunt (which I don’t have at the moment).
Resistances to ground: pin 1 - 0.3, pin 2 - 1.95k, pin 3 - 4.8M

I have similar (never used) , resistances are similar, 1 = 0 ohm, 2=1.9k 3 = 3M and is rising up to 15M while capacitor is charging. Apply external 5V to Vin through 100 ohm resistor ?

5V on vin works like a charm. And this USB cable will work on another NodeMCU I have. Weird. I just double checked my other one and I’m getting better voltages, about 4.55 on Vin through the USB, and 3.28 through the regulator. So it would appear that the problem is still this unit, with the voltage somehow getting messed up from USB pin to the board. I think I’ll just leave it alone. It’s a little more hassle, but it works now, and I can use the regulator.

Using micro USB, check voltage on both sides of resistors in the loop, on one of them should be 5V

So here’s what I found that was very different. The highlighted component has a 400mV voltage drop on the good board, and it’s about 2.9V on the bad one, so I’m guessing that’s the problem is that piece has been destroyed. I can’t tell what component it is though.

EDIT: turns out it’s a schottky diode. It doesn’t seem really necessary. It looks like it mostly just feeds off of the USB 5V to prevent back-feeding via Vin to USB. I have some regular diodes, I think 1N4007, can I just use one of those?

yes, expect voltage drop 0.6V

Looks like that should be fine. But I might just leave it. Even though the diode is messed up and has a really high voltage drop, it is still stopping back-flow of current, and I could even just remove it and leave it open, maybe fix it later if I really feel the need at some point…or harvest a diode from something else…looks down at a broke BluRay player I have sitting next to me

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.