Erratic servo motion

I used for some time a servo controlled with a knob (almost unchanged example sketch in arduino library) than from a certain time on the servo started moving erratically. I tried with another servo and that was ok so I thought the servo was defective. Contacted the provider and obtained a replacement servo, but same behaviour. The two identical servos move erratically while a third (cheap from HK) servo woks ok. Tried also another arduino board with the same result. What could make my sketch or boards (they are Nano v3) work with one servo and not with the other, although from some time same sketch and board worked ok with all servos? I'm really puzzled!

The servo knob example encourages the bad habit of powering the servo from the Arduino 5V: rather give it its own supply as shown below (for 3 servos: ignore 2 of them 8) ).

Using the Arduino 5V is often the cause of servo “funnies”.

servo power.png

Hi, As Jimbo say's could be a power problem, and yes we all know not to power anything really from the arduino's 5V line, use a seperate battery pack for this. The only other thing could be the gears in the servo have broken, not likely unless put under a great strain, etc, especially cheap ones with plastic gears.

Regards

Mel.

Servo has metal gear, and works ok with a RC model RX (just tried). Didn' try yet the external 5V yet, however. You may be right. I took an external 5V from 2s Lipo regulator since the whole project will include several servos, didn't think the Arduino 5V could have issues even with 1 servo only, so I was actually running the firts tests without external servo supply, and only one servo. I'll try as you suggest and let you know, many thanks!

After very long time (project was in standby for months) I gave it a try yesterday according to your suggestion: dedicated 5V power for the servo, not taken from arduino 5V regulator. And I'm glad to report it worked ok at the first attempt! Thank you to those who helped me. ;)