error compiling for board arduino uno

Hi guys, i’m fairly new to this, i just got a uno rev.3 and AdafruitMotor Shield v2.3 a project i’m attempting for my sim racing setup, links bellow

the issue i have is when i try to verify i get the following error

Arduino: 1.8.2 (Windows 10), Board: “Arduino Uno”

WARNING: Category ‘’ in library EEPROM is not valid. Setting to ‘Uncategorized’
WARNING: Category ‘’ in library SPI is not valid. Setting to ‘Uncategorized’
WARNING: Category ‘’ in library SoftwareSerial is not valid. Setting to ‘Uncategorized’
WARNING: Category ‘’ in library Wire is not valid. Setting to ‘Uncategorized’
Warning: platform.txt from core ‘Arduino AVR Boards’ contains deprecated recipe.ar.pattern="{compiler.path}{compiler.ar.cmd}" {compiler.ar.flags} {compiler.ar.extra_flags} “{build.path}/{archive_file}” “{object_file}”, automatically converted to recipe.ar.pattern="{compiler.path}{compiler.ar.cmd}" {compiler.ar.flags} {compiler.ar.extra_flags} “{archive_file_path}” “{object_file}”. Consider upgrading this core.
C:\Users\Todd Linnett\Desktop\ShakeItPackage\Arduino\ShaketItFirmwareMotorShieldV2\ShaketItFirmwareMotorShieldV2.ino:11:34: fatal error: Adafruit_MotorShield.h: No such file or directory

#include <Adafruit_MotorShield.h>

^

compilation terminated.

exit status 1
Error compiling for board Arduino Uno.

This report would have more information with
“Show verbose output during compilation”
option enabled in File → Preferences.

I’m not sure how to resolve this error any help would be appreciated
I’ve attached to code as well

ShaketItFirmwareMotorShieldV2.ino (2.98 KB)

(deleted)

that did the trick, thanks :slight_smile:

Unrelated to the error, but you’re using a very outdated version of Arduino AVR Boards. I recommend you update to the most recent version:

  • Tools > Board > Boards Manager…
  • Wait for downloads to complete
  • Click on “Arduino AVR Boards”
  • Click “Update”
  • Wait for update to complete. (should be very fast because you already have the latest on your computer, it’s just being overridden by the old version).
  • Click “Close”.