Error interpretation

please interpret this error for me

sketch\src\findCable.cpp.o (symbol from plugin): In function findCable()': (.text+0x0): multiple definition of findCable()'
sketch\My_FI_Version.ino.cpp.o (symbol from plugin):(.text+0x0): first defined here
C:\Users\Bill\AppData\Local\Temp\ccVzPH3o.ltrans0.ltrans.o: In function `findCable':

I cannot find multiple definitions in the program

Hi @ruggb. Please post your full sketch.

  1. Select Tools > Auto Format from the Arduino IDE's menus. This will make it easier for you to spot bugs and make it easier for us to read.
  2. Select Edit > Copy for Forum from the Arduino IDE's menus.
  3. In a forum reply here, click on the post composer field.
  4. Press Ctrl+V. This will paste the sketch to the post composer.
  5. Move the cursor outside of the code tags before you add any additional text to your reply.
  6. Repeat the above process if your sketch has multiple tabs.
  7. Click the Reply button to post your reply.

When your code requires a library that's not included with the Arduino IDE please post a link to where you downloaded that library from or if you installed it using Library Manager (Sketch > Include Library > Manage Libraries in the Arduino IDE) then say so and state the full name of the library.

Me neither.

1 Like

I can't even find one.

How many fingers am I holding up?

1 Like

Please post the FULL error output, and your FULL code, along with links to any libraries used. or if this has been downloaded from the internet, post a link to the page it is on.

So the error messages are not decipherable, right?
It isn't pointing to a line number
It says I have multiple definitions in the file that it is in
then it is pointing to a file in the temp folder as the first place it appears.
I tried compiling a program that previously compiled - no changes - it is giving me errors in a library file that also previously compiled with that program.

I reinstalled Arduino and the library -same thing

the error appears to be in the library

I have reinstalled the IDE and it tells me the library is already installed, but it is a special one that I dnld from github.

How do I get rid of it so I can reinstall it.

this is the library
C:\Users\Bill\Documents\Arduino\libraries\Adafruit_TFTLCD\Adafruit_TFTLCD.cpp:873:0: warning: "read8" redefined
#define read8(x) x=read8fn()

In file included from C:\Users\Bill\Documents\Arduino\libraries\Adafruit_TFTLCD\Adafruit_TFTLCD.cpp:19:0:
C:\Users\Bill\Documents\Arduino\libraries\Adafruit_TFTLCD\pin_magic.h:192:0: note: this is the location of the previous definition
#define read8 read8inline

C:\Users\Bill\Documents\Arduino\libraries\Adafruit_TFTLCD\Adafruit_TFTLCD.cpp: In member function 'void Adafruit_TFTLCD::begin(uint16_t)':
C:\Users\Bill\Documents\Arduino\libraries\Adafruit_TFTLCD\pin_magic.h:410:25: warning: large integer implicitly truncated to unsigned type [-Woverflow]
hi = (d) >> 8; lo = (d); CD_DATA ; write8(hi); write8(lo); }
^
C:\Users\Bill\Documents\Arduino\libraries\Adafruit_TFTLCD\pin_magic.h:196:29: note: in expansion of macro 'writeRegister16inline'
#define writeRegister16 writeRegister16inline
^~~~~~~~~~~~~~~~~~~~~
C:\Users\Bill\Documents\Arduino\libraries\Adafruit_TFTLCD\Adafruit_TFTLCD.cpp:352:5: note: in expansion of macro 'writeRegister16'
writeRegister16(ILI9341_VCOMCONTROL1, 0x2B2B);
^~~~~~~~~~~~~~~
Sketch uses 31246 bytes (12%) of program storage space. Maximum is 253952 bytes.
Global variables use 1286 bytes (15%) of dynamic memory, leaving 6906 bytes for local variables. Maximum is 8192 bytes.

thhapufoatriscosi

LAST CHANCE :

Please post the FULL error output, and your FULL code, along with links to any libraries used. or if this has been downloaded from the internet, post a link to the page it is on.

The above was the FULL error message starting at the first C:\......
The code I used was one from the original author of this project that previously compiled with no errors with the indicated library.
Posting my code won't do any good. However, a previous version that also compiled gives me similar errors.
It has been working. Therefore something went wrong. I want to get it all off my computer so I can reinstall it clean but somehow it does not go away. I guess I just need to do it on another computer.

Well you know better then. Bash on, I'm out.

1 Like

I included the library file
#include <Adafruit_TFTLCD.h> // Hardware-specific library
in my Marlin.ino (for my 3D printer) file and it produced the same errors. However, the program still compiles. There is no code requiring this library in the Marlin program and the program also compiles just fine without them.

So, is there a problem in the library file or in my new program?
I got the library here
It ran fine for the first 100 or so compiles that I attempted.

All of a sudden there is a problem with it and I can't remove it to install a fresh copy.

Who knows?

There are somewhere around fifty or sixty folks here who will offer help. That number dives to zero or close to it if you decide not to give them the data they ask for.

Good luck, we're all counting on you .

since this did not produce and error prior to me updating the library files, what I found was that I had updated a GFX library to 1.10. The TFT library creates errors with anything over 1.5.3 so I regressed to 1.5.3 but I am still getting these warnings (which are fewer than I got with 1.10)
Therefore, one of the other libraries that I updated must be causing the warnings but I have no clue which one and I don't remember all that I updated.
If no one else has run into this then I guess it is a hunt and peck operation to find one of the libraries to regress.

The data that is being asked for has nothing to do with the problem since it exists whenever I include this library in ANY ino file.

It has nothing to do with any ino, it is some interaction between libraries. Any ino the library is included in, whether it uses these libraries or not, does compile as these are only warnings.

What I find is that running anything higher than 1.5.3 of the GFX library will cause it to not compile. The first time I run the compile with it at 1.5.3 it produces the warnings but compiles the program. If I click the verify button again, IE don't close the IDE, it compiles without the warnings.

Any ideas or do I just ignore the warnings?

UPDATE: Thanks for all your help. Obviously, no one has ever had this issue b4. But the symptoms logically did not point to a code issue. What I did was to load everything on my laptop and it all compiled fine. SO, the problem WAS NOT in any code but some interaction of Arduino IDE with my system. I reimaged my system and everything is running fine now. Yea, I know, hard to believe.