Errors at : CP2102 with ATMEGA328P-PU

Hi

I’m trying to make the above two components work togother, but I keep getting errors.

I followed the video at: 1-Day Project: Build Your Own Arduino Uno for $5 - YouTube

I’mattaching the step-by-step build of the solution. I tried to replace the capacitors at picture #13, but it didn’t work)
I keep getting errors:

Arduino Sketch upload issue - avrdude: stk500_recv(): programmer is not responding

Can anybody help?
Daher.

Do you have a bootloader on the chip?
A 10K resistor from 5V to the reset lead sometimes helps.
A 0.1uF capacitor across power and ground on a digital IC as near as practical to the device .

Hi
Thanks for the reply.

I added the 10K resistor and the 0.1uF capacitor. Please see in the attached pictures. I have different versions of it as seen in pictures: 40,50,60

My initial version without the 0.1uF capacitor (but with the 10K resistor) can be found in picture #30

All of them didn’t work and still returning the same error as seen in the file: #80

With respect to the boot loader:

I bought it with the intention to have the boot loader on it. I bought it from eBay as ATMEGA328P-PU (see picture #90) but what I got was chip labelled: ATMEGA328P/U (see picture #70)

Could it be that the chip that I got is without boot loader and this is the reason why it is it not working properly?

Any advice how to workaround this?

Thanks in advance
Daher.

70.png

And the programmer is...?
Are you trying to use USB/serial with CP2102 (because CP2102 is a chip) for ISP programming? It doesn't work.
You will need ISP programmer like USBasp or Arduino with ISP sketch.

Could it be that the chip that I got is without boot loader and this is the reason why it is it not working properly?

In your original pictures you had the led connected. A momentary short to GND on the Reset lead will cause the led to flash about 3 times if the bootloader is on the chip.

This may help if you don't have a bootloader on the chip.

http://www.gammon.com.au/forum/?id=11637

Hi

Thanks for the feedback. Apparently, there wasn’t a bootloader on the ATmega chip and I followed the instructions at: Gammon Forum : Electronics : Microprocessors : How to make an Arduino-compatible minimal board to upload a bootloader.

Though, despite the fact that I fixed it, the CP2102 didn’t work.

I workaround the problem by using an existing Arduino UNO R3 board to upload the ATmega chip and it worked.

Daher.

Make sure you use the CP2102 correctly. If the ATmega328P has the bootloader then it is able to upload via serial port.
This the first assumption. Secondly, minimal circuit is needed consist of power with decoupling, oscillator and reset circuits.
Then, from the CP2102 the Tx, Rx and DTR or RTS signals are needed.