Ethernet Shield + Router with Password

I know it might sound like an old topic and even already solved but I’ve been looking for a solution without success.

I cant interface my Arduino w/ethernetshield and my router, I’ve tried disabling firewalls, opening ports but I cant get it to work.
this is my code please help me…

#include <SPI.h>
#include <Ethernet.h>

// Enter a MAC address and IP address for your controller below.
// The IP address will be dependent on your local network:
byte mac = { 0xDE, 0xAD, 0xBE, 0xEF, 0xFE, 0xED };
byte ip = { 192,168,1,120 };
byte server = { 173,194,33,104 }; // Google
byte gateway ={ 192, 168, 1, 254 };

// Initialize the Ethernet client library
// with the IP address and port of the server
// that you want to connect to (port 80 is default for HTTP):
Client client(server, 80);

void setup() {
// start the Ethernet connection:
Ethernet.begin(mac, ip, gateway);
// start the serial library:
Serial.begin(9600);
// give the Ethernet shield a second to initialize:
delay(1000);
Serial.println(“connecting…”);

// if you get a connection, report back via serial:
if (client.connect()) {
Serial.println(“connected”);
// Make a HTTP request:
client.println(“GET /search?q=arduino HTTP/1.0”);
client.println();
}
else {
// kf you didn’t get a connection to the server:
Serial.println(“connection failed”);
}
}

void loop()
{
// if there are incoming bytes available
// from the server, read them and print them:
if (client.available()) {
char c = client.read();
Serial.print(c);
}

// if the server’s disconnected, stop the client:
if (!client.connected()) {
Serial.println();
Serial.println(“disconnecting.”);
client.stop();

// do nothing forevermore:
for(;:wink:
;
}
}

Just my two cents, but that gateway ip does not sound correct. I you sure it is not 192.168.1.1? That’s way more common than what you have.
Second, have you tired adding subnet tou your Ethernet.begin?

Appreciate that you take your time to read my post, I’m not sure if im in the right section.

ok, when I log on my router home settings I always use 192.168.1.524, when I was using the ending .1 i noticed connection failed faster; I also added subnet as you suggested and it takes more time before I get “connection failed”, this lead me to think that all the settings are allright but I keep getting rejected by what i suspect is my router PaSSword. I really dont know much about networks.

this is my code so far… the one that takes longer before “connection failed”

#include <SPI.h>
#include <Ethernet.h>

// Enter a MAC address and IP address for your controller below.
// The IP address will be dependent on your local network:
byte mac = { 0xDE, 0xAD, 0xBE, 0xEF, 0xFE, 0xED };
byte ip = { 192,168,1,120};
byte server = { 173,194,33,104 }; // Google
byte gateway = { 192, 168, 1, 254 };
byte subnet ={255, 255, 255, 0 };

// Initialize the Ethernet client library
// with the IP address and port of the server
// that you want to connect to (port 80 is default for HTTP):
Client client(server, 80);

void setup() {
// start the Ethernet connection:
Ethernet.begin(mac, ip, gateway, subnet);
// start the serial library:
Serial.begin(9600);
// give the Ethernet shield a second to initialize:
delay(1000);
Serial.println(“connecting…”);

// if you get a connection, report back via serial:
if (client.connect()) {
Serial.println(“connected”);
// Make a HTTP request:
client.println(“GET /search?q=arduino HTTP/1.0”);
client.println();
}
else {
// kf you didn’t get a connection to the server:
Serial.println(“connection failed”);
}
}

void loop()
{
// if there are incoming bytes available
// from the server, read them and print them:
if (client.available()) {
char c = client.read();
Serial.print(c);
}

// if the server’s disconnected, stop the client:
if (!client.connected()) {
Serial.println();
Serial.println(“disconnecting.”);
client.stop();

// do nothing forevermore:
for(;:wink:
;
}
}

I need help, please

I really dont know much about networks

That being the case, you may want to set the router back to the default settings. You don't say what router you have, but you would use the router's lan IP address for the gateway in the arduino code. Most home routers have 192.168.0.1 or 192.168.1.1 (depending on brand) for the default lan IP address.

If you're on windows, you can run "ipconfig" from a command prompt to see what the configuration of your network is. You want the arduino to have the same settings, except for the IP address, which should be unique in your local network. On a Mac or Linux, it's ifconfig you want to run from a console window.

I am sorry for the delay, I am from Mexico
this is what I see on my CMD / IPCONFIG

I’ve been using 192.168.1.254 and have tried ending .1
with no results

AFTER A LITTLE RESEARCH I FOUND OUT MY PROBLEM:
DECLARE SD SOCKET OFF / WIZNET ON & UPDATE GOOGLE IP
THIS IS THE FINAL CODE BASED ON THE ETHERNET/WEB CLIENT EXAMPLE * CORRECTED *

/*
Web client

This sketch connects to a website (http://www.google.com)
using an Arduino Wiznet Ethernet shield.

Circuit:

  • Ethernet shield attached to pins 10, 11, 12, 13

created 18 Dec 2009
by David A. Mellis

*/

#include <SPI.h>
#include <Ethernet.h>

// Enter a MAC address and IP address for your controller below.
// The IP address will be dependent on your local network:
byte mac = { 0xDE, 0xAD, 0xBE, 0xEF, 0xFE, 0xED };
byte ip = { 192,168,1,177 };
byte server = { 74, 125, 159, 99 }; // Google
byte gateway ={ 192, 168, 1, 254 };
byte subnet ={ 255, 255, 255, 0 };

// Initialize the Ethernet client library
// with the IP address and port of the server
// that you want to connect to (port 80 is default for HTTP):
Client client(server, 80);
const int SDchipSelectPin = 4;
const int ETHERNETchipSelectPin = 10;

void setup() {
// ------------ Set pin modes … ----------------------------------------------
pinMode(ETHERNETchipSelectPin, OUTPUT); // pin 10 → make sure that the default chip select pin is set to output, even if you don’t use it: pinMode(10, OUTPUT); // set the SS pin as an output (necessary!)
pinMode(SDchipSelectPin, OUTPUT); // pin 4 → On the Ethernet Shield, CS is pin 4 pinMode(4, OUTPUT); // set the SS pin as an output (necessary!)

// -------- Start ethernet --------------------------------
digitalWrite(ETHERNETchipSelectPin, LOW); // turn on the W5100 chip! by default it will be ON, so unnecessary.
digitalWrite(SDchipSelectPin, HIGH); // but turn off the SD card functionality!

// start the Ethernet connection:
Ethernet.begin(mac, ip, gateway);
// start the serial library:
Serial.begin(9600);
// give the Ethernet shield a second to initialize:
delay(1000);
Serial.println(“connecting…”);

// if you get a connection, report back via serial:
if (client.connect()) {
Serial.println(“connected”);
// Make a HTTP request:
client.println(“GET /search?q=arduino HTTP/1.0”);
client.println();
}
else {
// kf you didn’t get a connection to the server:
Serial.println(“connection failed”);
}
}

void loop()
{
// if there are incoming bytes available
// from the server, read them and print them:
if (client.available()) {
char c = client.read();
Serial.print(c);
}

// if the server’s disconnected, stop the client:
if (!client.connected()) {
Serial.println();
Serial.println(“disconnecting.”);
client.stop();

// do nothing forevermore:
for(;:wink:
;
}
}

MANY THNKS TO YOU ALL

i just loaded your last version of web client and got lots of input on the terminal, then i disabled the 4 lines in the setup about pinmode about digital.write and it WORKED ALSO.

so i think that was not the problem.

( i use arduino UNO, arduino ethernet shield ( original ), arduino-0022 )