External power supply not working (Leonardo)

Hello everybody,

I'm trying to use my Arduino Leonardo with an external power supply.
I tried various power adapters as shown here: Arduino Playground - WhatAdapter
One with 12V/1.7A, another with 9V/0.8A. Also a 9V block battery (Arduino Playground - HomePage).

  • is in the center like it's supposed to be.

If one of these power supplies is plugged in, the L-LED on the board blinks a short time or sometimes not at all, and both LEDs (L and ON) flicker or are on constantly. After that nothing happens (the program on the board doesn't load). Connecting to the USB port or even a DC USB adapter works fine.

I tested it with another Leonardo board and it's the same, so it's not a problem with the board, I think.

Does anyone have an idea why none of these power supplies work?

Did you have some extra hardware connected on the board?
From what you describe the board must work fine with a external power source.
Check connections again

Connections are fine, I only plug in the power supply.
No other hardware is on the board.


You can try to measure with a multimeter the 5V pin after you plugged in your external power supply (adapter or 9V battery). Please search a tutorial because if you do something wrong, your board can be ruined. Also you will find it very usefull if you are new with arduino and electronics in general.

Before pluging the power supply, test the program runing on Arduino with the USB adapter or cable to see if the problem is in the code. If your board doesn't do nothing, please try to upload a simple program with an LED (blink or On-Off) and don't test the power supplies only if the code is flawless.

Also, please upload a picture with the arduino, the power adapter jack and the 9V battery jack, because I suspect that can be a problem with the jacks in your case, especially that when you are on USB your board seems to work. I think your problem is with the power supplies jacks that are not workin

The code is not the problem, it’s a simple blink LED sketch.

I tried to use the 12V/750 mA power adapter from my YAMAHA keyboard: the Arduino worked and loaded my sketch. Are the other adapters I used broken or of poor quality? I don’t get it …

And the 9V battery still doesn’t work: I exchanged the power supply jack with a new one. Maybe the battery is also of poor quality? (I attached an image.)

I’ll try that thing with the multimeter later.

So finally, I found a "solution" for my problems.

As a power adapter I can use a Yamaha PA-130A adapter. It's quite expensive, but at least it works. All other adapters I've tried fail.
For the battery-powered solution I tried 6 * 1.5V Mignon AA batteries (adds to 9V) and that works perfectly for me - using one 9V block battery doesn't work.

So, thank you for your help!

Try to buy alkaline batteries, because a regular battery doesn't do the work (you can read the specs on the pack before you buy it). When I heard of alkaline many years ago I thought there is some maraketing thing, but I tested my xBox controler with normal batteries and it doesn't starts at all.

Regarding the DC power adapters, please be very carefull and before you use it try to measure with a multimeter if it's not a regulated voltage power supply (usually those adapters are very big, not like the ones that you use to charge your phone). I had a problem with a 12V adapter that burned one of my Arduino boards because the voltage was variable and sometimes recorded even 17-18V.

I recomend to use a 9V power supply and that way you don't risk to destroy your board. I don't think that you need 12V for your projects for the moment.

elicat, this is bad solution for your problem.

You find out what's the problem?

I have 3 arduino uno board with ethernet shield with same problem......work only with usb and pc

I realise this issue has come up time and time again but I will have my say all the same,

I have recently purchased an Arduino Due and could not get my program to run when powered from the dc power connector.

I was using a 9V dc adapter with plenty of current capability but I could only get my program to run if I connected USB power.

Indeed by trying a different dc power adapter worked for me but I am guessing that the reason some adapters don't work and others do is due to the power supply design and its power up phase relationship with the Arduino Due, in particular the power reset mechanism. I haven't tried to fix this problem but I'm guessing the 47uF supply capacitor on the dc input circuit is an issue and affects the transient power up phase. I would have liked to see a decent power up reset circuit on this dc input but for now I shall continue with my experiments undeterred.

I hope someone can find the time to solve or admit to this problem soon.

Re the Ethernet board

I have a similar issue ( Arduino Mega and Ethernet Shield )

A ( new ) 9 volt battery is only delivering 2.5 volts ( on both the 3.3 and 5 v pins Tested with a multimeter )

With the Ethernet Shield removed I am getting 3.7 volts on the 5 volt pins

Better, but barely enough to power the LCD display ( also attached to the Mega )

Still looking for a solution to obtain 5 volts on the 5 volt pins with the Ethernet Shield and LCD display connected


The answer is mentioned above.
You need a better power supply.

Batteries are ok for most tests involving JUST the board but tend to have a very short life.
For longer use you would need a much better battery or a real power supply.

Try to stay below the 12 volt range if its a real arduino but clones are much more tolerant in that regards.