Fehlermeldung beim Compilieren

Hallo,
ich wollte grad ein 128x32 OLED Display teste, als ich diese Fehlermeldung bekam:

Mehrere Bibliotheken wurden für “SPI.h” gefunden
In file included from C:\Users\Kevin\Documents\Arduino\libraries\Adafruit-GFX-Library-master\Adafruit_GrayOLED.cpp:20:0:

Benutzt: C:\Program
C:\Users\Kevin\Documents\Arduino\libraries\Adafruit-GFX-Library-master\Adafruit_GrayOLED.h:30:10: fatal error: Adafruit_I2CDevice.h: No such file or directory

Nicht benutzt: C:\Users\Kevin\Documents\Arduino\libraries\SPI-master
#include <Adafruit_I2CDevice.h>

Mehrere Bibliotheken wurden für “Wire.h” gefunden
^~~~~~~~~~~~~~~~~~~~~~

Benutzt: C:\Program
compilation terminated.

Nicht benutzt: C:\Users\Kevin\Documents\Arduino\libraries\Wire-master
Mehrere Bibliotheken wurden für “Adafruit_GFX.h” gefunden
Benutzt: C:\Users\Kevin\Documents\Arduino\libraries\Adafruit-GFX-Library-master
Mehrere Bibliotheken wurden für “Adafruit_SSD1306.h” gefunden
Benutzt: C:\Users\Kevin\Documents\Arduino\libraries\Adafruit_SSD1306-master
exit status 1
Fehler beim Kompilieren für das Board Arduino/Genuino Uno.

Ich habe im explorer geschaut und konnte nur jeweils eine library finden und nicht mehrere. Kann mir bitte jemand helfen.

Vielen Dank im voraus

Das was du postest ist ein Hinweis, keine Fehlermeldung.

Du musst in den Einstellungen alle Meldungen anklicken, damit auch die Fehlermeldungen gezeigt werden. Da steht dann auch dein Problem drin.

Hallo Dieter,
danke für die schnelle Antwort. Könntest du mir genauer erklären wie du das meinst mit dem Anklicken aller Fehlermeldungen? Ich bin halt noch ein Neuling :sweat_smile:.

Danke im voraus

Gruß Kpex

Es gibt in der IDE im Menüpunkt Einstellungen mein paar Möglichkeiten verschiedene Dinge anzuhaken.
Da solltest du alle beim Kompilieren anzeigen, anhaken.

Hallo,
ich habe geschaut und habe bei den Voreinstellungen die folgenden Punkte angehakt. Ich habe es auch mit allen Punkten versucht, aber leider kommt die Meldung trotzdem und das Display funktioniert nicht. Du meintest schon die Voreinstellungen unter denen ich die Punkte abhaken sollte, oder?

Gruß Kpex

kpex:
error: Adafruit_I2CDevice.h: No such file or directory

Das scheint dein Problem zu sein. Da fehlt wohl eine Library.

kpex:
Hallo,
ich habe geschaut und habe bei den Voreinstellungen die folgenden Punkte angehakt. Ich habe es auch mit allen Punkten versucht, aber leider kommt die Meldung trotzdem und das Display funktioniert nicht. Du meintest schon die Voreinstellungen unter denen ich die Punkte abhaken sollte, oder?

Gruß Kpex

Nicht abhaken, sondern anhaken.

Aber Franz-Peter hat dir den Fehler schon gezeigt.

Sorry das habe ich tatsächlich überlesen.

MicroBahner:
Das scheint dein Problem zu sein. Da fehlt wohl eine Library.

Danke, nachdem ich die library gedownloaded habe ging alles. Den Fehler habe ich übersehen

Danke für die Rückmeldung. Viel Spaß weiterhin.

HotSystems:
Nicht abhaken, sondern anhaken.

Aber Franz-Peter hat dir den Fehler schon gezeigt.

Sorry das habe ich tatsächlich überlesen.

Sollte mir eher leid tun, ich habe den Fehler übersehen. Trotzdem danke

Gruß Kpex

kpex:
Sollte mir eher leid tun, ich habe den Fehler übersehen. Trotzdem danke

Gruß Kpex

Naja....wir lernen ja alle voneinander.

6 Augen sehen halt mehr als 2 :smiley: - dazu ist das Forum doch auch da.