FTDI and Arduino Pro Mini Problems. Help Please!!

Hi everyone,
A little background, I just finished assembling a quadcopter that is going to be controlled by a MultiWii SE V2.5 flight controller.
This controller is based on the Arduino Pro Mini (5v , 16 MHz) w/ ATmega 328 . It is supposed to be flashed through a FTDI Tool.

And now to the problems. When I try and upload code all I get is this message:

avrdude: stk500_recv(): programmer is not responding

I tried with Arduino 1.5.5 and got this:

avrdude: stk500_recv(): programmer is not responding
processing.app.debug.RunnerException
** at cc.arduino.packages.uploaders.SerialUploader.uploadUsingPreferences(SerialUploader.java:129)**
** at processing.app.Sketch.upload(Sketch.java:1672)**
** at processing.app.Sketch.exportApplet(Sketch.java:1578)**
** at processing.app.Sketch.exportApplet(Sketch.java:1550)**
** at processing.app.Editor$DefaultExportHandler.run(Editor.java:2399)**
** at java.lang.Thread.run(Thread.java:695)**
Caused by: processing.app.debug.RunnerException: Problem uploading to board.

First I thought the board is damaged, although its sensors were good. When connected with FTDI the Multiwii GUI worked properly.(A software that reads the sensors value) Still, I decided to try and check if the FTDI was working well.
So I used an Arduino Uno as a FTDI like shown here : Arduino Examples #2 Use an Arduino As a FTDI Programmer : 3 Steps - Instructables

This time, I received no errors while downloading the program onto the board, but the GUI showed only partial info if any.
After using the Uno as FTDI the board refused to make the motors spin by the command of the Transmitter. It only flashed its blue LED.

Well, I'm really confused, I don't know if the FTDI is broken or even if the "Uno Method" is actually working! Maybe just giving a bad upload. Because the program had changed. My assumption is that this particular MultiWii board is no good..

Any help would be great, thanks!

yorai

Hallo,

I had Simmilar head ache with FTDI / Uno board as Serial-interface and some chips with different bootloaders.

1st: there was a loose contact on the reset pin, "breadboard" problem. ( I found out later)

2nd: I tried to use the ATMEGA from the UNO board and swaped the Chip. -> the bootloader was then not matching.

3rd: I burned a new bootloader on the spare chip using the UNO board. -> ending with two chips with UNO bootloader.

Using the naked (without controller) UNO board as programmer -> working
as serial interface -> both devices were working fine -> wrong board selection seems to be no harm here.
FTDI chip as programmer of breadboard construction -> not working
FTDI chip as programmer of Arduino Pro mini -> working

The reason was that the board needs to be selected as UNO, because with the FTDI and the other board I had to change to Duemillanove.
If I plug the UNO as programmer in it selects the UNO board. Changes seem to be automatically, because swapping so many item. They are not. (Just tried again :slight_smile: )

So I succeeded in checking the reset ciruit -> plus check if the on the IDE selected serial port is matching with the communication chip & the board selection is matching with the bootloader on the chip. -> then today everything was working. -> all that appeared totally random.

Is it possible, that Pro Mini board has an UNO bootloader?

Greetings

ps. "naked" Uno as programmer is working with reset directly on RST pin of chip. -> FTDI is only happy with capacitor.
pps. I just tried the UNO board is loading nicely up to my ProMini remove the ATMEGA chip from UNO Pin0 connected to the RXI of the ProMini. UNO Pin1 to the TXO of the pro mini. Serial port selected /dev/tty.usbmodem411. Board Arduino Pro or Pro mini....

Thank you for your suggestions!
Today I tried uploading the sketch again with the BETA Arduino 1.5.5 after installing a driver for the FTDI.
Surprisingly, it worked!
But unfortunately no errors in the upload process does not mean that it works :~.
As time progresses I start to believe more strongly that the board is bad.
One pin sends bad signals and the overall behavior of the motors is not right.

Anyway, thanks for your help. I'll get a new board and update.

yorai

p.s. Is there any way to read the sensors with arduino Uno?

Did you try searching the board? This or similar errors comes up a fair amount of times.

Your Arduino probably has a counterfeit FTDI chip. Windows may have updated the driver, which doesn't seem to work with the counterfeit chips. Download and install an older version of the driver, it worked for me. I bought a couple of Nanos that won't work with the latest driver, but do with the driver downgraded.

Information in this thread:
http://forum.arduino.cc/index.php?topic=198681.msg1477473#msg1477473

Thanks for all your help!
I just figured out all I had to do in the first place was calibrate the ESCs...
I feel a little stupid now.. XD

Anyway, I need to learn to fly this thing now!
Although I still have some problems, like one motor getting to much power..
If anyone here can offer some quadcopter help please stand out :).

yorai