FTDI RTS Not Working since Kernel Update (2.6.35-25)

I did a kernel update on my Linux machine today (to 2.6.35-25-generic-pae) and I find that my FTDI cable suddenly won't auto-reset the arduino clone I have on a breadboard. In fact it's worse - it just seems to hold pin 1 low constantly.

I only managed to do an upload after having disconnected the RTS wire from pin 1, which means going back to manually pressing reset before an upload.

I was puzzling as to why this suddenly was the case... and thought about the recent kernel update. I tried booting back into 2.6.35-24-generic-pae and everything works as it used to.

I assume something's changed in a driver somewhere...

So this isn't really a question, more just to say what I've noticed in case anyone else is puzzled about strange new behaviour :) However, if anyone can shed more light on this, feel free to comment...

Related: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/690798

Which seems to confirm my theory that the driver has changed. Comment seems to imply that this is a deliberate change in the Linux code - therefore the IDE presumably needs a bit of a change to set RTS low when the port is opened.

I just updated to 2.6.35-25 myself, but it is working fine here on an official Duemilanove. It auto-resets on upload as normal. This is on Ubuntu 10.10 x86_64

See my post here about the FTDI cable not working with an older kernel:


I'm kind of glad I didn't try to fix it by upgrading my kernel because it looks like it's broken on the latest one as well. Apparently they randomly change the FTDI drivers' behavior for some reason. Do you remember what kernel you had before where the FTDI cable WAS working as expected? Since my netbook is basically my Arduino terminal, I'd just as soon use that kernel.

The kernel which worked for me was 2.6.35-24-generic-pae.

I've been bitten by this one too :(

My temporary fix is to cut the pads as per manual reset/upload then solder a 100nF cap across. This makes it a lot less fiddly than trying to time the reset just right, but I have to unplug-then replug in the board every time I want to make a fresh upload - go figure!

Coincidentally, there seems to be no problem with the mega, also I've tried using a little FTDI module from RS components, connecting just the serial lines, and the RTS# line via a 100nF cap. That works perfectly (which is why it took me so long to discover there was a problem). I don't know if it's relevant but this development board of my own doesn't share the +5V with the USB module.

This one was driving me crazy bonkers.

Here's a little compilation of screenshots I made: .

I tried crazy things, then I read of possible kernel borkedness.

So I rebooted 2.6.35-24, and it's there I'll be staying until this gets sorted out.

dmesg|grep ftdi_sio ftdi_sio 5-2:1.0: FTDI USB Serial Device converter detected uname -a Linux mark-laptop 2.6.35-26-generic #46-Ubuntu SMP Sun Jan 30 06:59:07 UTC 2011 x86_64 GNU/Linux

Everything works fine on Uno and duemilanove

dmesg|grep ftdi_sio [ 205.654534] ftdi_sio [u]5-2:1.0[/u]: FTDI USB Serial Device converter detected [ 205.656331] usbcore: registered new interface driver ftdi_sio [ 205.656335] ftdi_sio: v[u]1.6.0[/u]:USB FTDI Serial Converters Driver mark@mark-laptop:~$ uname -a Linux mark-laptop [u]2.6.35-27[/u]-generic #48-Ubuntu SMP Tue Feb 22 20:25:46 UTC 2011 x86_64 GNU/Linux

Just upgraded the kernel version and it working with Uno and duemilanove.

Have the people with issues checked to see if fdti released patched drivers for the new kernel?


hold pin 1 low constantly.

How did you measure this scope or meter?

@md81544 @dsacmul Which version of librxtxSerial are you using?