Get error occured when upload

Arduino: 1.8.13 (Windows 10), Board: "NodeMCU 1.0 (ESP-12E Module), 80 MHz, Serial, 115200, 4M (1M SPIFFS)"

Sketch uses 216551 bytes (20%) of program storage space. Maximum is 1044464 bytes.

Global variables use 34792 bytes (42%) of dynamic memory, leaving 47128 bytes for local variables. Maximum is 81920 bytes.

Uploading 220704 bytes from C:\Users\ciwaw\AppData\Local\Temp\arduino_build_277218/sketch_may26a.ino.bin to flash at 0x00000000

warning: espcomm_send_command: didn't receive command response

warning: espcomm_send_command(FLASH_DOWNLOAD_BEGIN) failed

An error occurred while uploading the sketch

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

already try to connected D3 to ground but still got error with flash

Something went wrong. It may be a wrong wiring, the wrong board selection, a bad cable, a failing board or simply choosing the wrong serial port. But as you failed to provide the necessary information for us to help you, you're on your own to with that problem.

i have try uninstalled and reinstalled the chip driver, Arduino IDE, Libraries, Board Configurations in board manager(Also tried different
-Tried connecting pin IO0 to GND with jumper only
-Tried rebooting my computer

my selected board: NodeMcu 1.0(ESP-12 module )

I guess you also own exactly that board?

Does your PC recognize it?

What does "Get Board Info" (in the Tools menu) return?

BN: Unknown board
VID:1A86
PID: 7523
SN:upload any sketch to obtain it
i'm not sure for recognize it

The USB vendor and product IDs tell you that the board contains a CH340 USB2serial converter chip. But the corresponding board isn't recognized. So you either have a quite exotic board or your board is broken.

Post a sharp picture of it!

is that mean i need to buy a new nodemcu ?

Unfortunately it may mean that. I would first check the driver for the CH340, I don't know how well that works on Windows as I never use that OS.