how to add New Boards to arduino 1.8.2

Hello Im trying to add new boards to arduino from github i added the URLs and put a copy of the files in the hardware folder ....and still nothing ....I have several controllers that arduino does not provide like atmega16& 32 Im trying to add those I really am trying to avoid messing with the boards.txt file does anyone know what Im not doing or what I am doing wrong ?

EITHER (not both!!!!)

Use board manager. Add the URLs to the board manager URLs in the settings. Then open board manager with tools -> board manager, select the desired board package (you want the one from MCUdude)

OR

Install manually - extract into a folder in the hardware folder in your sketchbook folder (document folder\Arduino - you may need to create the hardware folder there. With some cores, you can sync their github repo into the hardware folder.

See the installation section of MCUDude's MightyCore for more info: https://github.com/MCUdude/MightyCore

Never modify the files in the directory you installed Arduino to. It's not expecting that anymore, and windows will play games if you try to modify files there due to User Account Control File and Registry Virtualization if you're on Windows Vista or later too.

OK.... I added the URLs and deleted the extra folders ..went to boards manager and they do not show up ?

at all I looked in contributed and then in all boards and i do not see anything new I made sure i put the

URL in correctly so Im stumped once again ?

OK i went with option 2 …Worked :smiley: Thanks DrAzzy …

I am using the LINUX IDE, and despite having downloaded the hourly build OF it, I am still unable to see the additional boards option of the >file>preferences menu.....

how do i workaround this?

also the add libraries facility is also fuckries....

Punkty24: I am using the LINUX IDE, and despite having downloaded the hourly build OF it, I am still unable to see the additional boards option of the >file>preferences menu.....

Would you mind posting a screen shot so I can investigate? If you click the "Reply" button, you'll see an "Attachments and other options" link that will allow you to make an attachment.

Punkty24: also the add libraries facility is also fuckries....

If you can provide a detailed description of the problem, I'll do my best to help.