I bricked my Arduino Pro Micro?!

So i retried everything again - but my pro micro still seems to be completely bricked. After a codeupload to the pro micro failed, nothing worked anymore and the Board wont even be recognized as a com port on my pc, only after a double click on the reset, and then only a short period. i through the software running on it crashed constantly since it didn't upload completely. So fair enough, i connected an arduino nano as arduino isp and - well it worked, i successfully burned a new bootloader on the pro micro and after that even uploaded an examplecode (the analogvoltage read) which uploaded successfully through the isp setup and the pro micro got recognized again after that on the pc and printed the readings on the serial monitor. That was 2 day ago tho, and since than nothing makes sense anymore!
After the pro micro got recognized again i tried uploading to it directly again through the usb - and it failed again and now seems to bricked the board even more.
Since the Board wont even be recognized as a com port on my pc, even after double reset push, i think its fair to say now even the bootloader doesnt work anymore, but if i try using the nano as isp again, i just get the error "Yikes! Invalid device signature"...
What can i do now?
And no my nano isp setup still works, i can still program other nanos that i have laying around through it

You will need to select a com port. COM1 will do if you have it, else hook up the Nano and select its COM port; disconnect the Nano.

Select the ProMicro as the board and upload an innocent sketch. When the IDE reports the memory usage, double tap the reset button (you will have to wire one if not done so already).

//Note
I might have misread your post. If your board can't be programmed using icsp, it might be beyond repair. Is anything else connected to the SPI pins?

Hi,
What variant of the ProMicro do you have 5V/16MHz or 3V3/8MHz?

Have you another controller to check the integrity of the IDE and USB cable?

Tom... :smiley: :+1: :coffee: :australia:

If you uploaded an example code per ISP after you burned the bootloader, the bootloader is lost again. Uploading per ISP overwrites anything in the micro. You must burn your bootloader again, and after that uploading any program only per bootloader.

But how can i do that?
The device wont be recognised by the pc or listed in the device manager. How can i select a com port for a device that is never found? Even after double reset on the board, which usally let the bootloader be on for 8sec?

To your note, no its just a breakboard with the cables from the nano to the pro micro

5V 16mhz, and yes, i can program other chips with the isp setup, so the usb cable or ide cant be the problem

But i cant do that either, the error ist the same when trying to burn the bootloader...
This 'yikes' messages drives me slowly crazy ._.

??? You told that you could successfully load the bootloader via ISP:

Oh well, I said that was 2 days ago tho, since than, nothing makes sense anymore, because after the bootloader was burned, it tried uploading the sketch through the usb of the micro again (which failed again) and at that point even isp wont work anymore, neither a program upload or a complete bootloader burn

I'm going to ask you to post some additional information that might help us to identify the problem.

Please do this:

  1. Select File > Preferences from the Arduino IDE menus.
  2. Check the checkbox next to "Show verbose output during: upload".
  3. Click the OK button.
  4. Attempt to burn the bootloader, just the same as you did before.
  5. After the Burn Bootloader process fails, you'll see a button on the right side of the orange bar: Copy error messages. Click that button.
  6. Open a forum reply here by clicking the Reply button.
  7. Click the </> icon on the post composer toolbar. This will add the forum's code block markup (```) to your reply to make sure the error messages are correctly formatted.
    Code block
  8. Press Ctrl+V. This will paste the compilation output into the code block.
  9. Move the cursor outside of the code block markup before you add any additional text to your reply.
  10. Click the Reply button to post the output.

So here is the error message :slight_smile:

Arduino: 1.8.13 (Windows 10), Board: "SparkFun Pro Micro, ATmega32U4 (5V, 16 MHz)"

C:\Program Files (x86)\arduino-1.8.13\hardware\tools\avr/bin/avrdude -CC:\Program Files (x86)\arduino-1.8.13\hardware\tools\avr/etc/avrdude.conf -v -patmega32u4 -cstk500v1 -PCOM42 -b19200 -e -Ulock:w:0x3F:m -Uefuse:w:0xCB:m -Uhfuse:w:0xD8:m -Ulfuse:w:0xFF:m 



avrdude: Version 6.3-20190619

         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/

         Copyright (c) 2007-2014 Joerg Wunsch



         System wide configuration file is "C:\Program Files (x86)\arduino-1.8.13\hardware\tools\avr/etc/avrdude.conf"



         Using Port                    : COM42

         Using Programmer              : stk500v1

         Overriding Baud Rate          : 19200

         AVR Part                      : ATmega32U4

         Chip Erase delay              : 9000 us

         PAGEL                         : PD7

         BS2                           : PA0

         RESET disposition             : dedicated

         RETRY pulse                   : SCK

         serial program mode           : yes

         parallel program mode         : yes

         Timeout                       : 200

         StabDelay                     : 100

         CmdexeDelay                   : 25

         SyncLoops                     : 32

         ByteDelay                     : 0

         PollIndex                     : 3

         PollValue                     : 0x53

         Memory Detail                 :



                                  Block Poll               Page                       Polled

           Memory Type Mode Delay Size  Indx Paged  Size   Size #Pages MinW  MaxW   ReadBack

           ----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ----- ---------

           eeprom        65    20     4    0 no       1024    4      0  9000  9000 0x00 0x00

           flash         65     6   128    0 yes     32768  128    256  4500  4500 0x00 0x00

           lfuse          0     0     0    0 no          1    0      0  9000  9000 0x00 0x00

           hfuse          0     0     0    0 no          1    0      0  9000  9000 0x00 0x00

           efuse          0     0     0    0 no          1    0      0  9000  9000 0x00 0x00

           lock           0     0     0    0 no          1    0      0  9000  9000 0x00 0x00

           calibration    0     0     0    0 no          1    0      0     0     0 0x00 0x00

           signature      0     0     0    0 no          3    0      0     0     0 0x00 0x00



         Programmer Type : STK500

         Description     : Atmel STK500 Version 1.x firmware

         Hardware Version: 2

         Firmware Version: 1.18

         Topcard         : Unknown

         Vtarget         : 0.0 V

         Varef           : 0.0 V

         Oscillator      : Off

         SCK period      : 0.1 us



avrdude: AVR device initialized and ready to accept instructions



Fehler beim Brennen des Bootloaders.

Reading | ################################################## | 100% 0.02s



avrdude: Device signature = 0x008000

avrdude: Expected signature for ATmega32U4 is 1E 95 87

         Double check chip, or use -F to override this check.



avrdude done.  Thank you.