Import Library, Add Library problem

I need some help with the Sketch, Import Library, Add Library
I downloaded a fresh copy of the Arduino 1.5.6 r2 IDE and let it install to its default folder under Windows 7. That install works well.
I then downloaded the unto my desktop.
Then invoked the Arduino IDE and performed the sketch, import library, add library command.
It ran OK. There is now a folder named Freertos20130714 located via the path from
c:\Users\Norm\My Documents\Arduino\libraries\FreeRtos20130714. All the files and sub-folders of the RTOS are present from that location in the tree.
But when I load the sample frBlink I get many errors, the first one of which reads...
frBlink:10: error: 'xSemaphoreHandle' does not name a type. There are about 16 related error messages.
It seems that the IDE is unable/unwilling to find the additional libraries.
If I run the verify using the BlinkWithoutDelay, it verifies fine.
What is it I am missing? I followed all the steps as currently documented on the Arduino WEB site


You have made mistake here. Once you downloaded zip file There is folder called library. There are 3 library file copy those individual file and pasted in Arduino library folder. after that you go to whatever example you want to test for example
E:\arduino-1.0.5-r2\libraries\FreeRTOS_AVR\examples\frBlink just click . It will not give error this time.i have already tried out let me know if any error after this step

it mine path:

I copied the FreeRTOS20137014 as you suggested. The path to the frBlink file now also exists at the end of the following path.
C:\Program Files(x86)\Arduino\libraries\FreeRTOS20130714\libraries\FreeRTOS_AVR\examples\frBlink\frBlink.ino
It also continues to exist where the original Import Library – Add Library placed the folder i.e.
c:\Users\Norm\My Documents\Arduino\libraries\FreeRtos20130714\libraries\FreeRtos_AVR\examples\frBlink\frBlink.ino
It still does not work.

Here what i have done. Check that you have done in same way. I got no error. Paste your step of snapshot to understand what your doing.

Here it library look like when import lib from zip file

Hello AMPS-N,
That worked!
I was copying in the entire tree of folders as they showed up on my desktop following the unzip.
So simple, so easy to make complex. Murphy must be watching over me.
Thanks again,