#include <TimedAction.h> Error on ide 1.0 ** SOLVED **

Hi,

I was trying to use the TimedAction lib. in the ide 1.0 from the example:

//this sketch will blink an LED at pin 13 each second
#include <TimedAction.h>

//this initializes a TimedAction class that will change the state of an LED every second.
TimedAction timedAction = TimedAction(1000,blink);

//pin / state variables
const byte ledPin = 13;
boolean ledState = false;


void setup(){
  pinMode(ledPin,OUTPUT);
  digitalWrite(ledPin,ledState);
}

void loop(){
  timedAction.check();
  //do something else
}

void blink(){
  ledState ? ledState=false : ledState=true;
  digitalWrite(ledPin,ledState);
}

and the ide 1.0 gives this error

 in file included from helloTimedAction.cpp:2:
C:\Documents and Settings\CAMOLAS\Ambiente de trabalho\arduino-1.0\libraries\TimedAction/TimedAction.h:33:22: error: WProgram.h: No such file or directory

Any idea from where is the problem? Can i use some lib simular that works in ide 1.0?

(compiles well in arduino-0022)

Thanks

Any idea from where is the problem?

Yes. You downloaded and installed Arduino 1.0 without reading the release notes.

You posted your message here without thinking that maybe 100 people have already posted the same error, and gotten help.

Can i use some lib simular that works in ide 1.0?

Yes.

Hi,

Any hellp please? still cant solve me problem =(

Thanks

Have you read the release notes? Have you searched the forum, and read some of the 40 pages of results for wprogram? The answer is there, many, many times.

If you haven't done the above, what have you tried?

Hi,

I search a lot for TimedAction.h with no sucess… read the release notes to… (im new to arduino sory) now with you hellp pointing me the god way i will do a new search for wprogram and then try to solve my problem.

Thanks

Hi,

Here is the way to solve the problem, in the lib change #include "WProgram.h" to #include "Arduino.h" in here you will find all the changes for ide 1.0 http://blog.makezine.com/2011/12/01/arduino-1-0-is-out-heres-what-you-need-to-know/.

Thanks