Intellisense in IDE 20 beta? [solved]

Hello,
I’m pretty sure arduino IDE is supposed to have intellisense like in vsc but I can’t get it to work. it worked at one point but now it won’t work anymore. does anyone know how to fix this?

File → Preferences → Editor Quick Suggestions. Put a tick in the box.

1 Like

That tick box needs fixing.

When File → Preferences is opened the tick is empty. Tick it and the option is turned on. When File → Preferences is opened again it is once again blank. Tick it again and the option is turned off.

It currently acts as a toggle with the tick box only confirming you are actually ticking it, not showing the current status of the option.

EDIT: I also find if I use a board like the ATtiny3217 (using megaTinyCore), the option is not functioning at all (neither the hover popups). It does work for all the other boards I tried.

Willem.

I have noticed the same bug with that preference. I haven’t found the time to submit a bug report for it yet. You are welcome to do so here:
https://github.com/arduino/arduino-ide/issues

I actually prefer to not have these pop-ups automatically because I find them distracting. You can trigger them on-demand with the Ctrl/⌘ + Space keyboard shortcut.

This is a known bug:

Hopefully a solution will be found.

Thank you! Turns out I just hade to change the preferences :slight_smile:

Thanks for the details. I have reported the problem:
Problem Preferences Quick Suggestions tick box. #313

The popups can be of assistance, so I like them. However they are mostly positioned covering the related text. I found if I change the Hover Delay to, say 1200ms, it gives time to position the cursor and edit without the popup appearing. By hovering for a heart beat or two, the popup appears.

I noticed two issues with this.

  1. When opening a new tab the original 300ms is used - not the newly specified 1200ms. You need to reset the value and enter 1200 again and all tabs are now obeying the 1200ms. Also closing and opening the sketch all the tabs again use 300ms - ignoring the changed delay.

  2. If I start a header (.h) or a .cpp file in a new tab (remember to include arduino.h) the popup position is perfect, right above or right below the selected text. Only .ino files/tabs seem to have the positioning problem.

Could someone please check and confirm this.

Willem.

1 Like

I saw that:

Thanks so much!

This is a known bug:

Sounds like you’re already working on your next bug report! This sort of feedback is very valuable. It’s the thing that will only be noticed when you have a lot of users trying out every possible thing you could imagine. Probably a small group of testers would never think to change from the default value. This is why it’s very good that Arduino decided to release Arduino IDE 2.x now in its beta stage rather than waiting until a production release was ready.

The non-.ino files don’t undergo any sketch preprocessing so the line numbers don’t change. I’d guess that’s the reason for the difference.