Issue: Burning Bootloader in Atmega328p using Arduino ISP and 8 MHz internal clk

So…

I was trying to burn the Arduino ISP bootloader to my external Atmega 328p microcontroller. I intend to use the internal 8 MHz clock in the Atmega 328p microcontroller chip for this purpose.

The board I am using is Arduino UNO.

The reason being, I already made a PCB for my circuit and I don’t have any footprint there to put external Oscillators and capacitors in the circuit for now.

I followed this page for the setup (the part without the external oscillator):-

whenever I try to burn the bootloader to the external Atmega328p microcontroller, I get this error.

======================================================================
Arduino: 1.8.13 (Windows 10), Board: “ATmega328, Yes (UART0), EEPROM retained, 328P / 328PA, BOD 2.7V, LTO disabled, Internal 8 MHz”

C:\Users\sdebba3\AppData\Local\Arduino15\packages\arduino\tools\avrdude\6.3.0-arduino18/bin/avrdude -CC:\Users\sdebba3\AppData\Local\Arduino15\packages\MiniCore\hardware\avr\2.1.0/avrdude.conf -v -patmega328p -cstk500v1 -PCOM4 -b19200 -e -Ulock:w:0x3f:m -Uefuse:w:0b11111101:m -Uhfuse:w:0b11010110:m -Ulfuse:w:0xe2:m

avrdude: Version 6.3-20201216

Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/

Copyright (c) 2007-2014 Joerg Wunsch

System wide configuration file is “C:\Users\sdebba3\AppData\Local\Arduino15\packages\MiniCore\hardware\avr\2.1.0/avrdude.conf”

Using Port : COM4

Using Programmer : stk500v1

Overriding Baud Rate : 19200

avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0xff

avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0xff

avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0xff

avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0xff

avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0xff

avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0xff

avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0xff

avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0xff

avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0xff

avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0xff

avrdude done. Thank you.

Error while burning bootloader.

Please help me in solving this issue. Thank you very much.

Shibam

Did you remember to upload the |Arduino as ISP sketch to the Arduino?
How have you wired everything?
Can you post a picture (Close and in focus) of your setup?

The resp=0xff usually points to shortage on ISP wires.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.