Issue with Arduino Nano can't comunicate via serial with SIM5320

Hello there tinkers 8) .

Before starting I would like to explain what I’m trying to achieve and what I have done so far and what is the actual issue.

I got myself a SIM5320 3G+GPS module to be used for vehicle tracking.
Initially to power this beast I’ve used Raspberry Pi 3b+ 5V and GND GPIO pin hooked to the 5V & GND to SIM5320 module and via USB cable connect SIM5320 USB port to Raspberry PI USB port for communicating via USB serial. This is all fine and good as I can run AT commends throw USB serial at 11500 baud rate (default baud rate).

Because of the size and power requirements to run Raspberry Pi I decide to use Arduino Nano micro controller (ATmega328) and here where the issues begins.

Leaving SIM5320 power via Raspberry GPIO pins (because it require 5V @ 2A peak) I’ve gone ahead and connect SIM5320 RX pin to Arduino RX(digital pin 2) pin and TX to TX (digital pin 1) pin

while also following GreatScott’s video “Make your own GPS SMS Security Tracking System”

Connection diagram

Using the code from the video and by replacing Arduino Uno with Arduino Nano diginal pins number, complied successfully, uploaded the sketch and openned Serial Monitor and writing “AT” command does not returned “OK” status as It was from video nor when was executed via Raspberry PI USB serial port and Yes I’ve changed baud rate in Serial monitor too.

#include <SoftwareSerial.h>

SoftwareSerial SIM(1,2);

void setup() {
    Serial.begin(4800);
    SIM.begin(4800);
}

void loop() {
    while (SIM.available()) {
        Seria.write(SIM.read());
    }

    while(Serial.available()){
        SIM.write(Serial.read());
    }
}

Initially I’ve though I should run FONA library to set baud rate to something like 4800. Upload that sketch again to Nano, SIM5320 ones again did not respond to any of the “Set baud rate” sketch.
Then I’ve decide to hook SIM5320 again with Raspberry PI USB port and execute “AT+IPREX=4800” command manually and reset the module.
Then hook up RX & TX pins from SIM to Nano and It was the same result or sometimes returned “?” characters when tried with different baud rate.

I’ve then head to internet If someone else is having the exact same issue, while do some suggested lowering default 11500 baud rate to lower like 9600 while mine is below that, others suggested connecting RX From Sim5320 to TX on Nano but no luck there either.

Before I forgot, I’m using ARDUINO 1.8.12 on Windows 10 if this makes any difference.
That been said any help will be appreciated as I’m stuck with this for 2 days.

Update: Removed Raspberry pi from the power the SIM5320 and instead hook it into Arduino Nano 5V & GND GPIO pin.

Also manage to get NMEA sentences send back from module, if is set GPS to automatically start when module is powered , but I'm unable to interact with it.


(Open image in new tab to see full resolution)