Just recieved board, and - red led blinking at 1s on 1s off - Good/bad?

Hi there,

I'm trying to follow the initial tutorial at https://www.arduino.cc/en/Guide/MKRVidor4000 and I've installed:

  • IDE : 1.8.7
  • arduino SAMD beta boards (32-bits ARM cortex-M0+) 1.6.24

the board when plugged in does appear as COM Port 3 and appears in the Board Tools menu and is selected (it's the only one I have plugged in).

The blinking red LED next to the USB is indicating some issue, but I've tried to upload

  • First the blink sketch

This failed with :

Arduino: 1.8.7 (Windows 10), Board: "Arduino MKR Vidor 4000"

....>>>>  SNIPPED (see attached file for full log) 


PORTS {COM3, } / {COM3, } => {}
Uploading using selected port: COM3
C:\Users\preet\AppData\Local\Arduino15\packages\arduino\tools\bossac\1.7.0-arduino3/bossac.exe -i -d --port=COM3 -I -U true -i -e -w C:\Users\preet\AppData\Local\Temp\arduino_build_761737/Blink.ino.bin -R 
An error occurred while uploading the sketch
processing.app.SerialException: Error opening serial port 'COM3'.
 at processing.app.Serial.<init>(Serial.java:147)
 at processing.app.Serial.<init>(Serial.java:82)
 at processing.app.SerialMonitor$4.<init>(SerialMonitor.java:101)
 at processing.app.SerialMonitor.open(SerialMonitor.java:101)
 at processing.app.AbstractMonitor.resume(AbstractMonitor.java:104)
 at processing.app.Editor.resumeOrCloseSerialMonitor(Editor.java:2078)
 at processing.app.Editor.access$1400(Editor.java:114)
 at processing.app.Editor$DefaultExportHandler.run(Editor.java:2056)
 at java.lang.Thread.run(Thread.java:748)
Caused by: jssc.SerialPortException: Port name - COM3; Method name - openPort(); Exception type - Port busy.
 at jssc.SerialPort.openPort(SerialPort.java:164)
 at processing.app.Serial.<init>(Serial.java:136)
 ... 8 more
Error opening serial port 'COM3'.

Things that I've tried:

----------- LATER ---------------

Ok further on.

Saw this article Hands-On With New Arduino FPGA Board: MKR Vidor 4000 | Hackaday that mentioned double clicking the reset.

Doing this sets the red light to become 'breathing' and then board jumps to another COM port.

Ok so I can upload on the board in this mode now but I have to swap the com port, every time I want to see the results.

Every time I've uploaded, the serial monitor closes and I lose all my output from the previous session. is this the expected workflow?

Is there an updated tutorial I can follow please?

arduino message.txt (15.4 KB)

VidorRedLightCap.zip (335 KB)

Have you tried this?

I've also attached a screenshot showing how I uploaded a VidorDrawLogo sketch into my Vidor4000 board just now.

If you can successfully connect to your board via an online IDE then find the SAMD_BOOTLOADERUPDATER within the libraries and update the bootloader. After that you should not have any problems.

Best regards.
B

Thank you - I've done the update.

Welcome to the Arduino SAMD bootloader updater

Checking if bootloader requires an update ... bootloader is NOT running the latest

Would you like to proceed with updating it? (y/N)

WARNING: DO NOT UNPLUG the USB cable during the update!!!

Updating bootloader ...

0.00%
6.25%
12.50%
18.75%
25.00%
31.25%
37.50%
43.75%
50.00%
56.25%
62.50%
68.75%
75.00%
81.25%
87.50%
93.75%
100.00%

The bootloader was successfully updated \o/

Your board will now start blinking in joy :slight_smile:

Great!