lcd e i2c

Ciao a tutti...

stavo seguendo questo tutorial: http://garagelab.com/profiles/blogs/tutorial-lcd-using-only-2-arduino-pins-with-pcf8574-and-i2c

ho realizzato questo cablaggio:

ma non mi funziona... sul display non compare nulla.. ho un display 16x2 tradizionale

qualcuno saprebbe aiutarmi?

mi rispondo da solo.. risolto grazie a

http://www.ti.com/lit/ml/scyb030/scyb030.pdf

Sai che aiutiamo volentieri, ma siamo anche curiosi, cosa era il problema? Ciao Uwe

Le pull-up?

Io sinceramente ho scaricato la lib ma con l'ide 101 mi dice con non posso usarla pechè il nome deve contenere solo numeri e lettere.. Non mi è mai capitato,appena voglio aprire l'ide si apre questa piccola finestra con il messaggio e poi una volta chiusa mi apre l'ide. Sapete dirmi qualcosa?

Io sinceramente ho scaricato la lib ma con l’ide 101 mi dice con non posso usarla pechè il nome deve contenere solo numeri e lettere…
Non mi è mai capitato,appena voglio aprire l’ide si apre questa piccola finestra con il messaggio e poi una volta chiusa mi apre l’ide.
Sapete dirmi qualcosa?

Ho risolto…era solo dovuto al fatto che ho memorizzato la libreria in una cartella che ho chiamato lcd i2c e non accettava il fatto che fra la scritta lcd ed i2c ci fosse uno spazio :disappointed_relieved:

Sai che aiutiamo volentieri, ma siamo anche curiosi, cosa era il problema?
Ciao Uwe

Le pull-up?

Credo si riferisse alla differenza tra l’indirizzo del PCF8574 che è 0x20 e l’indirizzo del PCF8574A che è 0x38…
Confermi ?

tonid:

Sai che aiutiamo volentieri, ma siamo anche curiosi, cosa era il problema? Ciao Uwe

Le pull-up?

Credo si riferisse alla differenza tra l'indirizzo del PCF8574 che è 0x20 e l'indirizzo del PCF8574A che è 0x38.. Confermi ?

Confermo 8)

ad ogni modo, mi sembra leggermente più lento, meno reattivo, rispetto al collegamento tradizionale... è una mia impressione?

Non saprei dirti perchè ho sistemato il mio problema ed ho provato solo a fare un paio di scritte in punti diversi dell'lcd giusto per vedere se tutto andava bene ed effettivamente tutto funziona,anche io come te ho la versione dell'integrato con la A finale.... Comunque credo che un collegamento parallelo sia più veloce di uno seriale,dipende però dalla velocità di trasmissione dati dei due sistemi che io però non conosco bene.

Guarda qui --> https://bitbucket.org/fmalpartida/new-liquidcrystal/wiki/Home

Ci sono le prove comparative dei diversi tipi di connessione.

Per chi ha, invece, il modulino adafruit consiglio le nuove TWI2 --> http://www.adafruit.com/blog/2012/10/18/liquidtwi2-v1-0-a-lean-high-performance-i2c-lcd-library-for-arduino/ --> https://github.com/lincomatic/LiquidTWI2