leonardo blink sketch not uploading.. "buffered memory access not supported"

Hello Everybody,

I appreciate if anyone can help me solve this problem. I am new to arduino and recently bought a leonardo. The problem is I was not able to upload the basic blink sketch on to it... below is the error I got..

Binary sketch size: 4,858 bytes (of a 28,672 byte maximum) Found programmer: Id = "BsÄ"; type = Software Version = ; Hardware Version = avrdude: error: buffered memory access not supported. Maybe it isn't a butterfly/AVR109 but a AVR910 device?

I have seen 2 more threads where guys have faced the same problem. but they claim the prob got solved luckily by shifting to other ports.. Well I tried and I didnt get lucky..

I have checked the correct com port in the IDE version 1.0.1. Driver installed properly.. I am able to see Arduino Leonardo (Com11).. Also read the upload guide in the website for leonardo.. I tried the process where we have to hold the reset and release only when uploading.. starts.. The LED is blinking. It slows down and breaths when the IDE shows uploading. At the same time this happens I see a auto reset of Com11 in device manager..

I have tried front ports and back ports. In fact checked in every port of my computer. I am using WinXP professional service pack 3.

I heard great news about arduino and bought it.. but not so very happy.. Please help me...

Regards Somesh

Hi Somesh. Sorry to hear your first time experience with Arduino has not been so good. Is it possible to provide some screenshots of the error messages in the IDE so we can help you?

One question springs to mind. Is the Arduino Leonardo connected to the computer via a usb hub. If so, until you find the problem, make sure you connect directly to the PC. This goes for any Arduino problem troubleshooting.

Finally see this post http://arduino.cc/forum/index.php?topic=107273.0


Dale www.GorillaBuilderz.com

Check out eried's Arduino IDE Enhanced: http://arduino.cc/forum/index.php/topic,118440.0.html

The Leonardo is very fussy doing both USB comms and running sketches. I found if I hook up the USB directly to the "root hub" on my notebooks running XP, it tends to hang on uploads. I put it on a "USB Hub" and it fixed that problem. The problem I was unable to fix was the communications running a sketch and output to the serial monitor does not work on my XP machines but works fine on my Vista machine.

Anyhow, it's a good device but the guru's need to work out the kinks. Uno has had a lot of refining to get where it is.

Thanks… I will get you the screenshots…
I am directly connecting the leonardo to my desktop ports (front and back).

Will use a hub and try today…


Guys I tried my best to just know if this has a solution. very disappointed with this product (UNO must be good, but this one no idea) I could not solve why this is happening. Is there a reason when I plug in a USB based device and it some how resets it self often?

besides, why should one use a USB hub to connect? why cant the inherent problem be found out and solved.

If you don't need the ability to turn the thing into a mouse emulator or a keyboard emulator, you are probably better off with the Uno.

I've got a Leonardo, but it is fiddly uploading things to it. I hold down the reset button, wait till it says "Uploading" and then let go. This works about one time out of three.

Hi all:

I also got problems when loading a sketch for the first time. I tried everything but it was impossible. (Pressing the reset button before, during , after the upload message appeared didn't help me).

I use Windows XP.

In may case, I solve the problem by plugging the Leonardo to a different USB port on my Laptop. The drivers reinstalled themselves, a new virtual port was created and, after this, everything works fine. As I was using before a Mega on the first port, I thing something was mixed together.

Hello all!! I had the same problem with my Arduino Leonardo and my Windows 7. After trying many things, I found a solution. First: you must find the COMx used for your "Arduino Leonardo" in the "Device Manager" of Windows. Second: make double click to see the properties of the device, and go to the "Port configuration tab" Third: enter in "Avanced Options" and deactivate "Use FIFO buffers", and accept all changes.

That is it, now you can program your Arduino Leonardo without the error ..."buffered memory access not supported"

I hope this will be useful!!!! :) :)

Thank you so much !