My Arduino Editor became wierd with large line spacing

The main editor of the Arduino looks like the spacing between the line are very huge.

I have attached a photo for reference please help me out to make my Arduino IDE right again.

Does the problem persist if you close all Arduino IDE windows and the start the Arduino IDE again?

Yeah, It persist even after restarting arduino and restarting my computer

Please do this:

  • (In the Arduino IDE) File > Preferences
  • Click the link at the line following "More preferences can be edited directly in the file". This will open a folder that contains a file named preferences.txt. Note that folder location.
  • (On this forum topic) Click the "Reply" button.
  • Click the "Attachements and other settings" link.
  • Click the "Browse" button.
  • Select the preferences.txt file. Note that your operating system might hide the folder containing it by default. You may need to configure your file browser to show system folders.
  • Click the "Open" button.
  • Click the "Post" button.

This will allow me to reproduce your IDE settings exactly so I can investigate the problem.

Here you go.

FYI, I deleted the whole appdata folder located at C:\Users<User name>\Appdata\Local\Arduino15

but, the problem persist.

preferences.txt (3.09 KB)

Praveen2000:
FYI, I deleted the whole appdata folder located at C:\Users<User name>\Appdata\Local\Arduino15

OK, that was a good troubleshooting technique. As long as you closed the Arduino IDE before doing it, that will cause the IDE to revert to its default preferences.

So that shoots down my theory that the problem could be caused by something in your preferences.

I also tried replacing my preferences.txt with yours to be sure, and I can’t reproduce the problem.

Which operating system are you using?

Have you made any modifications to the Arduino IDE’s theme?

I am using windows 10.

I didnt made any modifications to the theme

Unfortunately, I'm stumped. Hopefully someone else here on the forum will have an idea.

Hi,

does it reset to ‘normal’ if you select Tools> Auto Format?

Has Win 10 had any updates?

You’re using IDE 1.8.10, can you try an earlier version such as 1.8.9 and see if that clears it?

Search on this site for ‘clean up instructions’ and follow them to you make sure you remove all traces of 1.8.10.

Peter

Thanks, I did all but none of them didnt solve the issue

Does it look normal when you open it in a normal editor (notepad++, vi)? You can attach your ino file as well and somebody might be willing check it.