Nano 33 IoT . Doesn´t is recognized when connected

Hi everyone,
I have one issue with Nano 33 IoT that suddenly doesn´t is recognized when connected .W hat I guess odd is the green Led on, but I can´t complete the upload in IDE because I can´t find any port.
I did update to drivers and software but can´t fix this problem. I think that damage my device. I regards to find someone to help me.
Detail: Other devices that are OK when connected.

The tricky thing about the boards with native USB functionality like your Nano 33 IoT is that the USB code that creates the CDC serial port is running on the same microcontroller as your sketch. This means your sketch code can break the USB code, or stop it from running.

Fortunately, there is an easy way to recover from this situation:

  • Press and release the reset button on your board quickly twice. You should now see the LED on the board pulsing, which means the bootloader is running. The double press causes the bootloader to run indefinitely (until the board is reset, powered off, or an upload is done), which means you don't need to get the timing of the reset just right.
  • Select the port of your board from the Tools > Port menu. The port number may be different when the bootloader is running so don't assume you already have the correct port selected.
  • Start an upload in the Arduino IDE.

The upload should now finish successfully. After this, you should be able to go back to doing normal uploads without needing to press the reset button. If you still need to do the reset trick to do uploads after this, the problem may be caused by your code. You can verify this by uploading a simple sketch like File > Examples > 01.Basics > BareMinimum.

First, l thank you very much for returned to me, but I’ve tried to make this is and unfortunately not worked. There is anything that I can be doing more?

Make sure the USB cable is completely plugged into both the Arduino board and the PC.

You may have a damaged/defective or charge-only USB cable. Try a different cable.

Either of the above can result in the power connections being made (and thus LED lights on the board), but no data connections (and thus no port for the board).