No matter what I do, I get this error avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0xbe

My problem is no matter what I do to upload a blink program to my Arduino pro-mini, I’m getting the not in sync error(below I have attached the error for reference).

Let me briefly explain my issue, I’ve like 60 pro-minis in that 30 are loaded with some code previously(and all are working fine), now I’ve lost the code because of my HDD issue(unfortunately I don’t have a backup) now the things is I’ve to code the remaining pro-mini with the same code, I tried to retrieve the code using AVR Dude but I was getting this not in a sync error. later I tried to upload using a blink program from IDE and cmd line too still I was getting the same error while uploading. So, I tried with another Promini to my surprise same error and another and another I tried all 30 pro-minis all are giving me the same error (All 60 pro–minis are from the same vendor), I tried to upload the blink program to the remaining 30 prominis it worked like a charm. I don’t know why the heck, those pms are not syncing. I tried uploading in different ways all to vein. What I observed is the pm’s reset led blinks rapidly for few seconds whenever I connect power and when I press the reset button and while uploading too. Please help me out here

Here are things I’ve tried:

  • I tried to upload using Arduino uno, Mega, USB - TTL, FTDI…
  • changed the USB cable.
  • tried with a different computer.

Nothing worked with the preloaded pms but worked with empty pms. I went through a lot of posts for around two weeks nothing worked.

Below is the error message

Arduino: 1.8.13 (Windows 10), Board: "Arduino Pro or Pro Mini, ATmega328P (5V, 16 MHz)"
Sketch uses 444 bytes (1%) of program storage space. Maximum is 30720 bytes.
Global variables use 9 bytes (0%) of dynamic memory, leaving 2039 bytes for local variables. Maximum is 2048 bytes.
C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avrdude -CC:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf -v -patmega328p -carduino -PCOM11 -b57600 -D -Uflash:w:C:\Users\BJI\AppData\Local\Temp\arduino_build_411622/sketch_apr15a.ino.hex:i 

avrdude: Version 6.3-20190619

     Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
     Copyright (c) 2007-2014 Joerg Wunsch
     System wide configuration file is "C:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf"

     Using Port                    : COM11

     Using Programmer              : arduino

     Overriding Baud Rate          : 57600

    avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0xce
    avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0xf7
    avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x6b
    avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0xa8
    avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0xee
    avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x4f
    avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0xa8
    avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0xbe
    avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0xed
    avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x9e

avrdude done.  Thank you.
An error occurred while uploading the sketch

This report would have more information with "Show verbose output during compilation" option enabled in File -> Preferences.

The things to verify are -

  • The Arduino is actually connected to the correct COM port as shown
  • The board/chip has a bootloader installed
  • The board is powered and connected properly
  • The code and uploader (avrdude) are configured for the correct board/chip/bootloader you have.

Note the dialog shows your upload is running at 57600, the default is usually 115200 bps

That short blinking at reset/restart is the bootloader trying to talk to any available uploader… it gives up if nobody responds - then runs whatever code is installed - if any.

Thanks for the response,

But as I mentioned earlier, my remaining pro minis are working fine with the same 57600 bps. The problems is all the 30 pro minis which are preloaded with a code are not accepting any new code (throwing the not in sync error). I have no idea how to override that.

If I try to upload code to the prominis (which are empty) the upload works and with the same setup I switch it with my other promini (which as a code in it) doesn’t sync at all. This is what bothering me.

Kindly help…

Well, you could work on one board to see if you can use ISP to program it…
either with a dedicated ISP programmer, or a second board working as ‘Arduino as ISP’
Do a search for that term.

1 Like

Thanks a lot man, I missed out to try Arduino as ISP. Thanks for pointing me there. It worked like a charm. ufffff finally after many head banging days I was able to succeed. :slight_smile:

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.