PH sensor giving constant value

First of all i dont really know where to put this topic, so sorry for that.

I have a ph sensor connected to a ESP8266 module.
I have calibrated it and it showing correct values in my test.

Then if i move it over to our outside pond. It’s only showing the value 3.47.
Then when i move it inside it shows the correct values again?
And i cant figure out what the issue is. So i hope anybody can help me here.

Things i have tried:
-Replacing the PH sensor
-Replacing the power adapter
-Replacing the ESP module

This is the sensor kit i am using:
Vloeibare PH Waarde Detectie detecteren Sensor Module Monitoring Control Board Voor Arduino BNC Elektrode Probe Controller|Integrated Circuits| - AliExpress
image

Do you have some other way to measure the PH of your pond?

What do you get if you take the sensor to the pond and test a glass of tap water?

Does it need calibration at startup?

I have measured the PH of the pond and its around 7.5-8.
When i fill a bucket of water and take it inside it measures these values.

I have taken the sensor in and out of power but it doenst need calibration.

Does it have something to do with the outside temperature mayby?

Sounds like a difference in how you power it at the pond then. Or perhaps that it’s harder to get the probe into the water there.

I power it the exact same way.
I even tried to measure the bucket there and its showing the value of 7.5-8

I’m quite out if ideas of what it can be.

So how do you get the probe into the pond when you get your acidic results?

Also, what is the bucket made of?

Hi,
Sounds like you have some electrical anomaly with the pond.
Does it have an electric pump?

What happens if you try the kitchen sink water in the sink.

If you lift a bucket water out of the pond and measure the Ph there beside the pond what do you get?

Tom… :grinning: :+1: :coffee: :australia:

1 Like

I just lower the probe into the pound. As far as that the whole PH probe is under water.
The bucket is made out of plastic

This is a good one.
I am going to try it into the kitchen sink now.

I have already tried to get the bucket out of the pool and i get correct values.

In the kitchen sink it shows proper values
image

Hi,
And it gave proper values in the bucket out at the pond?
But not in the pond itself.

Puzzling, could be something about the electrical characteristics of your pond.

How are you powering it, have you tried a battery bank, or are you using a plug pack?
If a plug pack have you tried another brand of pack?

Tom… :grinning: :+1: :coffee: :australia:

This has been asked before, but I repeat it: is there a pump or other electrical kit in your pond? If so, try lifting it out, or at least disconnecting it.

I have a vague recollection that PH sensors tend produce very small readings, need amplification and are finicky to use. If yours falls into that category, I suspect that TomGeorge nailed it in reply #8.

A most perplexing mystery indeed.

Okay this worked .
Thank you thank you.

Have tried another wall outlet and that one worked
So going to need to lay another tube under the ground for some power to our pond xD

Thanks agian for the help TomGeorge and Wildbill

Hi,
Great to hear… :+1: :+1:
It sounds like that plug pack that was the cause may have some earth leakage or substandard insulation, especially if it is double insulated.

Tom… :grinning: :+1: :coffee: :australia: