Problem of connection of Arduino Uno Rev 2

Hi, I am using the WifiNINA library in Arduino Uno Rev2. Uploading the AP_SimpleWebServer I noticed that the board doesn't connect to my router. It gives me only the IP to search. If I search it, nothing happens! Furthermore, it said that I need to upgrade my firmware. Indeed this was confirmed with the sketch CheckFirmwareVersion. This is the reason why I tried to upgrade it using the steps described in How to check and update the firmware of the WiFi Nina and WiFi101 modules – Arduino Help Center My problem is that in the list the last firmware (version1.4) is not shown. The last one is the 1.3 that I just had in the board (In serial Monitor uploading it is something that was requested to me). Thus I have 2 problems (I hope that there are related each other). The first one is that I can't reach the webserver with the IP that is indicated in serial monitor and the second one is that there is no the proper version of firmware to upgrade. What is the solution?

Hi @zewrx . I'm going to provide you with the instructions for updating the NINA firmware on the Uno WiFi Rev2 to the latest version. These instructions use the official command line tool for updating the firmware on Arduino boards. It is named "Arduino Firmware Uploader".

  1. Open this link in your web browser:
    https://github.com/arduino/arduino-fwuploader/releases/latest
  2. From the "assets" section of that page, find the version for your operating system. For example, if you are using Windows 64 bit, you want "arduino-fwuploader_1.0.1_Windows_64bit.zip". Click on it.
  3. Wait for the download to finish.
  4. Unzip the downloaded file.
  5. Open the unzipped folder in a command line terminal (e.g., Windows cmd, PowerShell, Bash).
  6. Connect your Uno WiFi Rev2 to your computer with the USB cable.
  7. Start the Arduino IDE.
  8. Open the Arduino IDE's Tools > Port menu. Take note of which port the Uno WiFi Rev2 is on. It will be identified in the menu by a suffix on the port name: "(Arduino Uno WiFi Rev2)".
  9. Return to the command line terminal you opened previously.
  10. Run the following command, replacing the "<port>" part at the end of the command with the port of your Uno WiFi Rev2.
    arduino-fwuploader firmware flash --fqbn arduino:megaavr:uno2018 --address <port>
    
  11. Wait for the flashing process to finish. This will take a couple minutes. You should see some output in the terminal indicating the progress.

Please let me know if you have any questions or problems.

Something is not working. I opened the file.exe inside the unzipfolder by mean of cmd. Nothing happens when I send the OK. Then I ran the arduino-fwuploader firmware flash --fqbn arduino:megaavr:uno2018 --address
COM4 is the name of the port but the prompt said that the syntax is not correct.

Please post the full and exact error you are getting from the command line teminal.

That was my mistake @pert . right now it is going, it seems

I'm glad to hear it's working now!