Problem with boarduino and firmata

I have a usb boarduino v2 from adafruit and am trying to use it with firmata and processing.

I am having trouble using my boarduino with the arduino firmata library - every time it needs to communicate something to processing, no reading is shown. I have uploaded the standard_firmata that is included with arduino but consistently see analog readings of zero. The boarduino works fine - when I use arduino's serial monitor readings are displayed.

I've tried the old firmata, the uno firmata, and the standard firmata - none work. The code works properly on my uno. Here's what I'm using in processing:

import processing.serial.*;
import cc.arduino.*;

Arduino arduino; 

void setup() {
  println(Arduino.list());
  arduino = new Arduino(this, Arduino.list()[0], 115200);
}

void draw() {
  println(arduino.analogRead(0));
}

Any advice on how to get readings?

make sure you have the right serial port(im guessing you do already). the code looks fine.

actually, maybe try A0 instead of 0: println(arduino.analogRead(A0));. when i use 0 in Arduino code it doesn't seem to work for me, but A0 always works.

  arduino = new Arduino(this, Arduino.list()[0], 115200);

The standardfirmata sketch in my IDE set the serial speed to 57600. Have you changed the speed in your version?

I've tried both - 57600 on firmata and processing, and then 115200 on both again. Still get no readings.

Putting A0 in the processing sketch gives me an error - cannot find anything named A0.