problem with driving stepper motor using L298N

Hi,

This is avi and am working on arduino uno, i was working on stepper motor driving using L298N, though program is proper and it is working on arduino uno, but when am trying to run the project on a general purpose PCB by following the same circuit schematics, the port pins are no longer working on uno board as well,

can anybody advice, about the following questions.

  1. is it necessary to use resistor pack to connect the L298N input pins directly to the input port pins of the controller or we have to connect through any resistor pack to drive this stepper motor circuit.

  2. the arduino circuit diagram schematics given in its website is same as the one i had designed, but still port pins are getting damaged or stops working.

3.what could be wrong ?

  1. following are the circuit schematics am working with.

Image from Original Post so we don't have to download it. See this Simple Image Guide

...R

avinash2099:
though program is proper and it is working on arduino uno, but when am trying to run the project on a general purpose PCB by following the same circuit schematics, the port pins are no longer working on uno board as well,

That reads as if the project you built on the PCB has caused your Uno to stop working as well. That seems very unlikely. My guess is that you have damaged the L298 - but that is just a wild guess.

Your schematic does not show how you have the L298 and the stepper motor connected.

Have you tried blinking some LEDs with your Uno and with your PCB version to verify that they are working properly.

If you need more help also please post the program you have tried and a link to the datasheet for your stepper motor.

...R
Stepper Motor Basics
Simple Stepper Code