Problem with flexiforce sensor A401 giving wrong readings

Hey guys!

So, I’m doing a project using the flexiforce A401 sensor from TekScan and I’m having some trouble setting it up. I’ve looked up on their website, and I found a PDF that explains the 3 types of circuits I can build: inverting op-amp, non-inverting op-amp and the simple voltage divider.

I’ve tried the simple voltage divider first, and the results were pretty good. I created a simple Arduino code and I was able to retrieve normal values from pressing the sensor.
The problem is that, I’ve tried to use the recommended circuit TekScan has for the non-inverting op-amp, and the results make no sense. I’m doing a simple analogRead and I’m getting around 500, when I’m not even touching the sensor. And if I do touch it, the value comes down, when it was supposed to go up.
They recommend the use of the MCP6004 op-amp, but as I didn’t manage to get that one, I’m using the TL074CN.
What do you think it may be causing this circuit to not work? I’ll leave the circuit and the results and I was getting with it here:

circuit_scheme.PNG

Your amp isn't rail-to-rail. Theirs is.

Show [u]your[/u] circuit.

Hi Dave!

Thanks for your reply. The circuit I've built is exactly the same I attached to my previous message, with the exception being the use of that different op-amp.

So, do you think the problem might be the op-amp and I should use a different one? I'm kinda noobie at this topic, so I don't really understand the difference between them. Can you recommend me a model to use there?

The image you attached is missing resistor values, voltages, whether grounds are connected, which Arduino you have..........

Oh, my bad, sorry.

So, basically: Vsupply = 3.3V R1 = 56Kohm R2 = 10Kohm Rfeedback = 100Kohm C1 = 47 pF;

And the arduino I'm using is the Arduino Uno.

How do your values of the following compare to what the datasheet for your op amp says are the…

  • minimum Vcc+
  • minimum total Vcc (Vcc+ - Vcc-)
  • minimum VCM (voltage common to both inputs…with your R1 and R2, your common mode voltage is 0.5V)

Yeh, I've just noticed that the minimum Vcm is +4V. I guess that's why it doesn't work?

Maybe, but I'd guess it has more to do with violating the other two limits.