Robot che aggira un ostacolo

Salve a tutti, sto preparando il mio progetto per la maturità che consiste in un robot che segue una linea e, se incontra un ostacolo lungo il percorso, lo deve aggirare; il problema sta proprio qua.
Il robot è dotato di due sensori ky-033 per seguire la linea e di un sensore ultrasuoni hc-sr04.
Ho deciso di fare i due programmi in maniera separata per poi unirli insieme in un unico sketch;per il segui linea non ho nessun problema, mentre per l’aggiramento dell’ostacolo non riesco a fargli leggere la presenza dell’oggetto durante la fase di aggiramento; qualcuno è disposto a dare un’occhiata a cosa non va nello sketch?

uso una clone della scheda adafruit per il controllo di due motori 3-12V dc e la controllo tramite la libreria “AFMotor”, inoltre uso un potenziometro per regolare la velocità siccome, non capisco il perchè, la scheda non fornisce tensione ai due motori in egual modo.

ringrazio chiunque sia disponibile a darmi una mano

Prova_aggira_ostacolo_5.ino (3.11 KB)

Ciao, ti invito prima di tutto a presentarti nell apposita sessione poi cercheremo di risolvere il problema

gioo123: essendo il tuo primo post, nel rispetto del regolamento, ti chiedo cortesemente di presentarti QUI ([u]spiegando bene quali conoscenze hai di elettronica e di programmazione[/u] ... possibilmente evitando di scrivere solo una riga di saluto) e di leggere con MOLTA attenzione il su citato REGOLAMENTO ... Grazie.

Guglielmo

P.S.: Qui una serie di link utili, [u]NON[/u] necessariamente inerenti alla tua domanda: - serie di schede by xxxPighi per i collegamenti elettronici vari: ABC - Arduino Basic Connections - pinout delle varie schede by xxxPighi: Pinout - link [u]generali[/u] utili: Link Utili

>littlebuilder: ... fai prima a copiarti il mio testo "standard" e mettere direttamente quello :D