Segmentation Faults

I am getting very frequent "Segmentation Faults" in a variety of projects. The solution that usually works is to clean the code or to simply move some code around, it usually compiles OK. That works most of the time, but not always.

There are always three error messages:
Severity Code Description File Line
Error fatal error: D:\Arduino\hardware\tools\avr\bin\avr-gcc returned 1 exit status lto-wrapper.exe
Error error: lto-wrapper failed d:\arduino\hardware\tools\avr\avr\bin\ld.exe -1
Error error: ld returned 1 exit status collect2.exe

and this warning:
Severity Code Description File Line
Warning internal compiler error Segmentation fault

Is there something that causes these segmentation faults? Is there a compiler upgrade that will fix this problem?

I haven't seen error messages in that specific format before, but there is a known problem with the newest production version of avr-gcc provided by Arduino. Here is my standard response for this issue:

This bug is specific to the 5.4.0-atmel3.6.1-arduino2 version of avr-gcc used by Arduino AVR Boards 1.6.22 and newer. It has been reported here:

Here's the traditional workaround:

  • Tools > Board > Boards Manager
  • Wait for downloads to finish.
  • When you move the mouse pointer over "Arduino AVR Boards", you will see a "Select version" dropdown menu appear. Select "1.6.21".
  • Click "Install".
  • Wait for installation to finish.
  • Click "Close".

Due to a bug, this workaround doesn't work with Arduino IDE 1.8.6, but it will work with any other version of the Arduino IDE.

If you have File > Preferences > Check for updates on startup checked, the Arduino IDE may occasionally notify you that a new version of Arduino AVR Boards is available, you'll need to refrain from updating back to the new Arduino AVR Boards version, otherwise you'll be back to seeing the segmentation fault error again.

Alternate workaround:
One of the Arduino developers recently worked on this and claims to have fixed it. There is a special beta testing hardware package you can install via the Arduino IDE's Boards Manager that has the fix:

  • (In the Arduino IDE) File > Preferences
  • In the "Additional Boards Manager URLs" field, enter: If you already have an additional Boards Manager URL in that field, you can separate multiple URLs with commas or click the button on the right side of the field to open a dialog that allows you to add each on its own line.
  • Click "OK"
  • Tools > Board > Boards Manager
  • Wait for the downloads to finish
  • Click on "Arduino AVR Boards by Arduino"
  • Click the "Update" button.
  • Wait for the update to finish.
  • Click "Close".

Thank you. This appears to have fixed the problem.

You're welcome. I'm glad to hear it's working now. Enjoy!