Serial2 Nano RP2040 in IoT Cloud Editor not working

Connected 2 Arduino Nano RP2040 Connect devices for a serial test.
RP2040 #1 in sender role, RP2040 #2 in receiver role.
Intention to use Serial2. Connected dev #1 pin D8 (TX) to dev #2 pin D9 (RX) and
dev #1 pin D9 (RX) to dev #2 pin D8 (TX).
Includes: <Arduino.h> and <WiFiNINA.h>.
For both roles Serial2 started in setup() with 'Serial2.begin(9600);'
The dev in receiver role tests availability of incoming characters with 'Serial2.available()'.
The dev in sender role tests availability to send with: 'Serial2.availableForWrite()'.
In both algorithms I inserted timeout counting. Both devices end with timeout.
Conclusion: not able to use serial communication via the Arduino IoT Cloud Editor environment.
I did similar tests b4 with the same setup, using CircuitPython. That worked OK.
Any advice is welcome.

Advice: Post your entire sketch, in code tags.

Problem solved by using pins 0 and 1 (Serial1). Now working.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.