SHIELD ARDUINO GSM V2 AVEC CONNECTEUR ANTENNE

Version IDE: 1.8.2

Tests modem sans carte SIM: le modem ne répond pas…

Essais avec autres cartes Arduino: même problème

Programme très succinct pourtant:

#include <GSM.h>
GSMModem modem; // modem à verifier
void setup()
{
Serial.begin(9600);
// start modem test (reset and check response)
Serial.print(“Starting modem test…”);

if(modem.begin())
Serial.println(“modem.begin() succeeded”);
else
Serial.println(“ERROR, no modem answer.”);
}
void loop()
{
}

Help me please !!!
Thanks

quel GSM, quelle librairie, comment est il connecté, comment est il alimenté, quel arduino (3.3V ou 5V) etc... vous ne pensez pas qu'il nous faut un peu plus d'infos?

Sorry,

La carte : shield Arduino V2 Quectel M10 montée sur une carte Arduino UNO

Bibliothèque : celle fournie avec la version 1.8.2

Exemple de test: Tool/ tests modem

Alimentation 5v par la carte Arduino

Bien à vous
Merci

la doc dit

. Power It is recommended that the board be powered with an external power supply that can provide between 700mA and 1000mA. Powering an Arduino and the GSM shield 2 from a USB connection is not recommended, as USB cannot provide the required current for when the modem is in heavy use.

vous alimentez comment votre Arduino?

Testé également avec une alimentation externe .

Idem…

Quelle alim? 2 amp ?

Yes. 2000 mA

vous avez essayé avec autre chose que 9600? on ne sait jamais...

sinon de mémoire je crois que les versions développeurs du shield nécessitent d'appuyer pendant un moment sur le bouton power du shield pour allumer le modem

J'ai fait mais je vais réessayer...

Merci pour ces infos

Le canard est toujours vivant...