[SOLVED]1.6.9 in Windows 10 Conflict with AntiVirus

I recently began running the IDE(1.6.6 and 1.6.9) in Windows 10. I have McAfee antivirus with real time scanning installed on the computer. When I try to compile any example or sketch I get the following error

C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-ar: unable to rename 'C:\Users\RICHAR~1\AppData\Local\Temp\build85fe9d593c6c3a472b2a54cc5e88b608.tmp\core\core.a'; reason: Permission denied

I do not have these problems in Win 7 with the same anti virus program.

Using Google and forum search for core\core.a errors I came across the following post pointing at permissions and anti virus issues.

I tried run as administrator, and several permissions and read only > full permission file changes, but the only thing I can make work is to disable the real time scanning in McAfee when compiling/downloading.

Does anyone have another solution?

There were two tag on PUPs as part of the new OS, ByteFence anti-malware, and some sort of "Cleaner"
performance optimizer and malware fixer. When I removed both those programs, the IDE compiles the examples and sketches without error with McAfee running as normal with real time scanning enabled.

Bytefence itself is apparently a legit program, but which (the free version) can sometimes be bundled along with another program. This is not to say that your 'offer' is legit or possibly a scam.
Is it just a message window, or also anything like here ? >

I'd first check in Programs and Features for it & uninstall. I'd use Uninstaller to also remove any remnants.

I'd also then run removal tool even if not in Programs and Features as it might be on your PC as a PUP.

This is probably a better clean up procedure