[Solved] Arduino IDE 1.5.7 Problem on Mac OSX 10.9.4

Hi there,
I installed the new IDE 1.5.7 version on my Mac running OSX 10.9.4 (which is although new).
When I try to start Arduino IDE, I get a message box saying "Unable to load java runtime environment".
Using 1.5.6 a day ago worked perfectly. And even going back to 1.5.6 works.

Solved it. One has to use the Java 6 package version of 1.5.7 even if the software download page of Arduino states that the other packages is supported on OSX 10.7 and newer. This was not true for my 10.9 OSX.

mamu:
Hi there,
I installed the new IDE 1.5.7 version on my Mac running OSX 10.9.4 (which is although new).
When I try to start Arduino IDE, I get a message box saying "Unable to load java runtime environment".
Using 1.5.6 a day ago worked perfectly. And even going back to 1.5.6 works.

Solved it. One has to use the Java 6 package version of 1.5.7 even if the software download page of Arduino states that the other packages is supported on OSX 10.7 and newer. This was not true for my 10.9 OSX.

If you insist on using the lasted abomination from (C)(R)Apple, then you have to be able to cope with stuff like this...

Ralf

PCWorxLA:
If you insist on using the lasted abomination from (C)(R)Apple, then you have to be able to cope with stuff like this...

Ralf

Sorry, didn't get it why it's an issue of new Apple Software. Using the packaging 1.5.7 which is not recommended for OSX 10.7 and above, everything works fine. So to me it's and documentation error on the Arduino software site.

mamu:

PCWorxLA:
If you insist on using the lasted abomination from (C)(R)Apple, then you have to be able to cope with stuff like this...

Ralf

Sorry, didn't get it why it's an issue of new Apple Software. Using the packaging 1.5.7 which is not recommended for OSX 10.7 and above, everything works fine. So to me it's and documentation error on the Arduino software site.

The main problem is that Apple makes a mess with it's Java deployment on each new OS X release, getting worth and worth each time.
They don't give a rat's a** about being compatible with anything or properly fix 3rd party dependencies. They live in their own little world and don't care about anyone or anything else.
Had at the same client, who insisted on upgrading to each new OS X release since getting a new MacBook last year, twice now the drivers for a printer\scanner stop working. Answer from Apple tech support: Get a new printer\scanner (though that is as old as the MacBook itself, a bit over a year)...
If you do any-non Apple related software development (like for an Arduino), simply don't use the latest and greatest (from Apple's POV)...

Ralf

PCWorxLA:
If you do any-non Apple related software development (like for an Arduino), simply don't use the latest and greatest (from Apple's POV)...

Ralf

This is only an option if they don't fix any security vulnerabilities or if you don't care about security at all.

And sorry, I still don't get it why its an issues of Apple and I have no indication that there is anything messed up regarding the latest 10.9.4 update. Can you point me to any note about this topic? If you are in software business, maybe you know about MS and there automatic updates on patch day or by using WSUS. This is how they deploy the latest updates.

mamu:

PCWorxLA:
If you do any-non Apple related software development (like for an Arduino), simply don't use the latest and greatest (from Apple's POV)...

Ralf

This is only an option if they don't fix any security vulnerabilities or if you don't care about security at all.

And sorry, I still don't get it why its an issues of Apple and I have no indication that there is anything messed up regarding the latest 10.9.4 update. Can you point me to any note about this topic? If you are in software business, maybe you know about MS and there automatic updates on patch day or by using WSUS. This is how they deploy the latest updates.

Microsoft does not apply any updates to Java with their updates, it's up to you to properly keep Java updated. The Java client software (or any SDK, if you have installed it) will make you aware of a new update being available when started and in turn, M$ will not through any wrench in your sprockets when you try to do that (beside that you need to have proper user permissions to do so).

Apple on the other side did (tried to) to provide the Java updates them self (in a half-arsed way), as they got anal about all the code signing crap. They claim it is all about security, which it is not. It's rather another ploy to keep you in their "walled garden" and make money of it by doing so.
If they would be really so security oriented as they claim (and droves of fanbois blindly follow), they would have updated the Java versions that they release to use Java 1.7 (which is the mainstream release for all other OS but Apple) a year ago. But instead, the official stance of Apple is that they don't supply any of such patches beyond Java 1.6 anymore. And their version checks apparently embedded in OS X (for security reasons, or so they claim) seems to keep trapping over the fact that Java 1.6 isn't Oracle's main release anymore. And fanbois seems to be oblivious to the fact that they don't get any updates from "their master" anymore and have to do something on their own if they are using any applications that require 3rd party components, like Java.

Specially OS 10.9 is breaking a lot of Java based apps, not only the Android IDE. The web is full of that, just look at all the complains from Eclipse or Netbeans users...

Ralf

Interesting vocabulary.

After reading this thread and trying to filter out the whining parts, I’m still confused on if I should install IDE 1.5.7 on my Macs, both of which are running OS X Mavericks 10.9.4.

Will someone in the know please advise?

Thanks,
Jake

Yes, go forward and install it! It’s faster and produces smaller code for Nano and Yun.
Simply try both download packages. On my Mac only the package named “runs on every Mac” runs.

Will do. Thanks!

mamu:
Yes, go forward and install it! It's faster and produces smaller code for Nano and Yun.
Simply try both download packages. On my Mac only the package named "runs on every Mac" runs.

Same here, running 10.9.4. The "10.7 and later" gives me the runtime error.